Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
I have a new hagon shock mounted to my Tiger , the one with the remote preload.
My problem is the shock was set up really soft and the bike is almost unrideable.
To adjust the preload I have to take the bastard thing out of the bike and adjust it.
I have the shcok out and have removed the grub screw on top of the shock but cant figure out how to tighten the spring ,
any suggestions would help as I'm stuck.
Pretty crappy design for something this expensive , yup I'm really frustratd right now
 

·
Registered
Joined
·
2,085 Posts
I've got my preload adjuster mounted on the subframe on the right hand side just below the join in the two saddles, so i can reach it whilst on the go.

When i got my shock unit, i adjusted the damping using the allen bolt in the shock itself, and then the preload using the manual adjuster.

I am struggling to think why yours doesn't 'firm up' I will say that the manual adjuster does take lots of turns from full on to full off ??

Not sure that helps, but that's all i can add for now....
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
even with the preload cranked all the way up it still handles like a bag of crap , so I need to tighten the spring more , it's like a pogo stick on crack right now
 

·
Registered
Joined
·
724 Posts
Could be wrong?

But is`nt the preload set for weight? ie- the sag for when the bikes not loaded the rear play should equal the front play, and the then cranked up for passenger or also luggage.

Have you checked the damping adjustment? if in doubt give Hagon an email, also how old is shock - as there seems to be an unlimited milage 2 year waranty on their shocks.
 

·
Registered
Joined
·
2,085 Posts
But is`nt the preload set for weight? ie- the sag for when the bikes not loaded the rear play should equal the front play, and the then cranked up for passenger or also luggage.
Thats what i meant......it was late.......d'oh!
 
1 - 5 of 5 Posts
Top