Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hi Guys

need help and valium ,

Went out for a run last night taking an s bend at about 50mph when lights and engine completly died on me ,pitch black managed to coast the bike into the side any ides only thing that would work were the indicators ????????????


To make matters worse called the AA who sent a recovery vehicle a flat bed with bike rack ,3 miles down the road heading home the bike toppled and ended up hanging of the side of the truck ,

bloody idiot of a recovery guy , so bike now out of commistion until insurance and repairs are sorted out !!

so any ideas on what caused the complete loss of electrics and engine power

cheers beaper
 

·
Premium Member
Joined
·
651 Posts
serious bummer, hang the recovery guy:confused:

I'd check the wiring around the frame neck and steering head. Any mid/high mileage T300 can have/show chaffed wires there. Also check the wires coming down from the ignition switch.

Of course, now having the bike f'd for you, maybe it'll get fixed with the rest of the repairs? One can hope:)
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
tHANKS

Cheers for the comments about the electric problem, but your right recovery company is going to take a hit for this ,bike will be better than before ,here,s hoping i get it back from the local techs before the snow comes again

cheers again beaper
 
1 - 3 of 3 Posts
Top