Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
i had ridden my 99 t309 for about an hour the other night when all the lights went dim and finaly the bike cut out??
i checked the output on the alternator and it was around 12.5 volts.
my question is is this normal voltage and if not what could the problem be?
 

·
Registered
Joined
·
105 Posts
To an extent it depends on what revs the engine was at when you checked it, but anything > 1000 rpm and you should be getting above 13.8 volts from the alternator to charge the battery. It sounds like your alternator may be dying, you ran on battery for a while until it gave up the ghost. What is the voltage across your battery, bike not running?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks for the reply
voltage across the batt was 12.3
if it is the alternator would a unit from a t312 work?
 

·
Registered
Joined
·
105 Posts
Battery doesn't look too bad, but then a load on it might drop the voltage considerably. As to the swapping an alternator I don't know, new to Trophy's. Hopefully someone more knowledgeable in that area will reply.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Thanks for replying
you wouldnt have an idea where i could find spares for this bike? as you can tell im new to this
 

·
Registered
Joined
·
105 Posts
Depends where you are, I'm in the UK.

Have a look on ebay, there's a load of different Trophy's being broken and sold off on there.
 
1 - 6 of 6 Posts
Top