Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi guys new to this so bear with me.
I bought a 97 955i speed triple that had a bit of cosmetic damage,Or so i thought!!!
I have an annoying electrical prob and was hoping ime not the first.
It will sometimes start ride fine then die for no reason,Ign light stays but all else inc lights and indicators fail+if you try and start it the dash lights go dim.That will sometimes last for 5 mins or sometimes a day or more.
Then it will work again,The other side is that sometimes it will do it from the off and just be dead when you try and turn it on.

I have changed most relays,checked for broken connections.

Hope someone can help!!!
Very frustrated as it is fantastic to ride when its well!!!
Thanks
Jim
 

·
Registered
Joined
·
201 Posts
Sounds like a grounding issue.

If I recall the T595s had an earthblock that was a common ground for the entire electrical system and it had a tendenancy to be a bit twitchy. I don't remember much past, but I read about it back when I first bought my Speedie.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thank you

Thanks for that
I have just read some threads on the problem you have mentioned and it seems exactly that.Same description down to every detail
I am going to my workshop in a bit and will report back
Thanks Again
Jim
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thank You Thank You Thank You!!!!!

You were right on the money.
Went to the bike,Turned it on Nothing
Wiggled the earth block that right in front of the battery
Hey presto it worked gave it a few more and it went on and off.
I will go and order the replacement part

Thanks again
Jim
Back on the road again and very happy!
 

·
Super Moderator
Joined
·
21,183 Posts
Welcome to the forum jimjammer. If you could go back yto your UserCP and fill in your bike year/model (under favourite bike) and your location, this will be helpful recognition for anyone going forward, without you having to repeat these identifiers - you will see that info is displayed under the screen names in the left margin.

Check out my posts & pics in this thread regarding your problem which as you have already identified appears to be the case of the infamous ground block. Worth checking with your dealer if it qualifies under the recall at no charge.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
updated

Have updated info,I will check out the local dealer in the morning,I have had a look at the replacement part and its only £3.55 but it looks a bit weak so will probably make my own out of the inners of a choc block,solder all connections and some epoxy resin.Definately like the additional cable to the earth terminal so i will add that whilst at it.
Thanks again to all for the help
Jim
 
1 - 6 of 6 Posts
Top