Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 2 of 2 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
I own a 2007 Triumph America never had a single problem with it.
I have 7200 miles on my bike and it has ran great all spring but yesterday when I was surrounded by Harley's at the annual spring ride (I estimate 500+ bikes and many of there owners showing interest in my bikes great looks) my bike failed to start when they were starting the ride. "This was embarrasing as they all rode by". It didn't roll over just made a faint click when I pushed the button. I checked all the fuses and a guy gave me a jump in case the battery was dead, still didn't roll over and after going through all the wiring I had called a tow service to bring it home.
Has anyone had this happen and if so what failed?:(
 

·
Registered
Joined
·
1,629 Posts
Feint click generally denotes that you have a weak battery. Why it is weak could either be a dropped cell in the battery....common if the bike isn't trickle charged over the winter in particular...or your rectifier/alt isn't kicking adequate voltage. What doesn't wash however is...the bike should have fired with a jump but didn't. If you couldn't get the starter to turn over with a jump then the following:
- Jump cables weren't good enough or secure enough.
- Bad starter or relay
- Loose connection
- Bad karma from hanging out with Harley riders. ;)

If you wash your bike, water could have gotten in there. Have to be careful with the hose if you use one on your bike. I try not to btw.

You can check your batt with a multimeter. Trouble shooting is in the manual also. Really need a MM and manual for these bikes if you want to save yourself some money. This board is invaluable as well.
Good Luck,
George
 
1 - 2 of 2 Posts
Top