Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
hiya, ive had my tiggger (2001)la couple of months now and its run perectly. ever since getting it ive been geting a noise from the fuel pump side of the tank, its a sort of buzzing sound , it doesnt happen all the time.
When it does "Buzzzz" it starts when the ignition is switched on(sounds like the fuel pump priming) then continues when the engine is started.At other times the ignition is switched on and no noise.
The bike doesnt appear to suffer in performance.
I just wondered if it was anything to worry about or if they all do it.
Thanks Daz
a couple
 

·
Registered
Joined
·
306 Posts
Mine does that as well.I just switch off and switch back on again.Normally that stops it,and returns things to normal.I have to say I have absolutly no idea why it does this.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
Cheers Superfour, thats set my mind at rest a little anyway:)
like i said it doesnt affect the running its just a little unnerving to have buzzing going on whilst riding.
Ill be replacing the fuel filter soon as part of a service so ill see if that makes a difference, if not ill not be too worried now.
Thanks
Daz
 

·
Registered
Joined
·
922 Posts
I think that the 2001 has a small pipe (my 2003 hasn't got one) on the tank next to the fuel conectors. this is the relief valve remove the pipe and squirt some WD40 up the nozzle. a few days later squirt some sort of lubricant up there and the noise should go. I give mine a quick squirt every 12 months.

dont run without the pipe if it is fitted, it connects down stream of the airfilter so dirty air can be drawn in
 
1 - 5 of 5 Posts
Top