Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Bike of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
So I noticed that my rear brake lights don't display a) when the bike is just on b) when braking.

I removed the light and hit the front brake while looking into the brake light and it seems very faint and tends to flicker on an off. Nothing like as strong as it should.
I ordered another rear brake light, installed it and same problem.

Any thoughts?
 

·
Registered
Joined
·
88 Posts
Sorry to hear. I'm not an expert but can't help to share some basic ideas since I've fiddled around with the rear light a lot recently;
*is all other electrics ok? - fuses-check
*There are a number of connectors and brakers from batt to light. Can you narrow down/isolate the problem by using a voltmeter and a separate batt (preferably through a separate fuse)?
For instance your first idea was rear light pack malfunc - you could have feeded the rear light on its first connector (from rear light) through separate batt directly and get ok diagnose and then move on.
*Depending on your interest, time and money getting the fairings off, inspect cables and run your tests you could contemplate seeking pro help.
*I'm not sure if a diagnostic tool like Tune Boy or Triumph original could help you out. I went through the DTC's (Diagnostic Trouble Code) but couldn't see a code for "pedal braker malfunc" for example...
Hope you get better answers from someone who's had a similar PITA. Good luck!
 
1 - 5 of 5 Posts
Top