Triumph Rat Motorcycle Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter · #1 ·
I installed K&N air filters on my '99 Adventurer when I removed the air box and those nice chrome side panels.

The air box had the mounting points for the side panels, so there's no place to remount the panels.

Has anybody fabricated a bracket or reinstalled the panels somehow.

Thanks,
Bonavent
 

·
Registered
Joined
·
4,122 Posts
I think Arfer made up some brackets to reinstall the chrome side covers after removing the airbox.
 

·
Registered
Joined
·
3,284 Posts
Glad this came up because I tried to post an answer and found that my bloody server was down!

So now it's running again, here's the links (click on the pic to go to the page) -



To really finish it off properly, the two holes that fit over the frame bolts should really be drilled bigger and a rubber grommet fitted to alleviate rubbing/scratching/vibrations etc'. It's not a problem, but it doesn't look very professional.

If you're really interested in making them, let me know and I'll go take measurements.

EDIT: Of course that's totally useless to you because you have pods!! That'll teach me to read the original post in it's entirety first :Dang DOH.
 
  • Like
Reactions: magbhw

·
Premium Member
Joined
·
708 Posts
Similar, but not the same, I wanted to re-install the original side covers, not the chrome ones. If you don't mind, I'll add this here as well as ArferBrick's, so it's all easier to find in the future?

I removed my entire airbox like you stated. In doing so, you lose the left side panel mounting tabs. I made up mount points to match the ones that are still on the right. Basically some flat steel, about 1" wide, make a bit longer then the stock ones on the right so you have something to weld to (made the 1st set the same length and didn't like how they would end up welded). I then drilled out a small hole in the center and inserted a small bolt that the shaft was the same diameter/length as the peg on the right mount tabs. We welded the bolt on to the tab first. We then ground the head down to clean it up some. Then the tab was welded to the left upper frame rail. Took some trial and error but using the left cover and taking measurements from the right tabs, it worked. For me it works just fine.

I also replaced the lower mounting bolts with twist off aluminum ones off a Bonneville/Thruxton. Had to re-thread the attached 'bolt' on the left frame rail to match the pitch of the right one. I have not had any issues with either.
 

·
Registered
Joined
·
123 Posts
Discussion Starter · #5 ·
Thanks for the responses - gives me some ideas. Arfer, is the air cleaner you use from the inside of the airbox? It looks like it works just as well as the airbox.
Mag, I don't see where I can mount anything on any side. I intend to get the old airbox out to see if I can use part of it.

Thanks again,
Bonavent

PS: I'm really enjoying the triple since I coated the tank and have clean carbs. I must have had them off a dozen times - one of the reasons I switched to pods.
 

·
Registered
Joined
·
3,284 Posts
Arfer, is the air cleaner you use from the inside of the airbox?
It's the K&N replacement for the original, can't remember the part number though - oh yes found it - TB-9095

Easy to rip out the original and replace it -

 
1 - 6 of 6 Posts
Top