Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
my 08 speed just threw a ck engine light and thinking it's due to my slip on pipe. i think all the packing blew out, bc it's considerably louder, and maybe caused it to throw the light? any thoughts would be appreciated. thanks guys.
 

·
Super Moderator
Joined
·
21,255 Posts
There is no way for that to be related to the MIL (Check Engine Light)

When did it come on? In middle of ride, stay on after start-up, or after you did some maintenance?

You should get yourself TuneECU to find which specific Error Code is responsible.
You don't specify your location (add this and your year/model permanently to your User Profile) but if in US, many auto-parts stores will connect an OBD2 reader and get the code for you, at no charge. e.g. Autozone
 

·
Super Moderator
Joined
·
21,255 Posts
Well sure, if the prime mover that turned it on initially 'resolves itself' it will clear (the light) after three complete warm-up cycles (however the error code will remain in memory)
- If it was my bike I would sure like to know what tripped it - unless it was after some maintenance with tank off, which most likely would have been due to turning ignition on while something was disconnected. Hence my questions about WHEN it appeared.
 

·
Registered
Joined
·
691 Posts
decoss is right about not being related but they don't just spit out packing. Maybe the baffle screw vibrated loose and you spit the baffle out like a cork on a bottle of bubbley :eek:
 
1 - 6 of 6 Posts
Top