Triumph Rat Motorcycle Forums banner

1 - 9 of 9 Posts

·
Premium Member
Joined
·
13 Posts
Discussion Starter #1
Would any have an idea why my '98 Trident wont fire on the center cylinder after sitting ,plug has to be cleaned then
fires up ok ( which is a task).
 

·
Registered
Joined
·
27 Posts
In my experience it was a broken electrode tip most likely as a result of not being regularly changed during servicing due to difficulty of access. It buried its wY into the piston head without any lasting damage fortunately


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
19 Posts
I have a 99 Legend TT and have been having similar issues with the #2 cylinder. I have replaced all 3 coils with Nology coils and the ignitor as well as spark plugs and wires. All seemed well until today. Bike sits a lot during the winter but this winter i made a habit if starting it up from time to time and again it seemed ok. Today i started it up to ride and #2 cylinder seems to be firing but the header for #2 is barely warm long after #1 & #3 are too hot to touch.
My first experience was about 6 years ago when the OEM coil #2 went completely dead, replaced and all was well for about 3 years. Then i started having intemittent backfires and loss of power to #2 so i replaced all three coils with Nology coils. Again all was well for a while. Then the bike sat for several months and in the spring #2 was again not firing consistently. Checked all of the coils and they all seemed to check out ok. I ordered and replaced the OEM ignitor with this https://www.carmo.nl/index.php?main_...155k0kura1qqp4 from Carmo. Again all seemed fine again so I got to ride for a while.
Any ideas?
 

·
Premium Member
Joined
·
13 Posts
Discussion Starter #6
I have a 99 Legend TT and have been having similar issues with the #2 cylinder. I have replaced all 3 coils with Nology coils and the ignitor as well as spark plugs and wires. All seemed well until today. Bike sits a lot during the winter but this winter i made a habit if starting it up from time to time and again it seemed ok. Today i started it up to ride and #2 cylinder seems to be firing but the header for #2 is barely warm long after #1 & #3 are too hot to touch.
My first experience was about 6 years ago when the OEM coil #2 went completely dead, replaced and all was well for about 3 years. Then i started having intemittent backfires and loss of power to #2 so i replaced all three coils with Nology coils. Again all was well for a while. Then the bike sat for several months and in the spring #2 was again not firing consistently. Checked all of the coils and they all seemed to check out ok. I ordered and replaced the OEM ignitor with this https://www.carmo.nl/index.php?main_...155k0kura1qqp4 from Carmo. Again all seemed fine again so I got to ride for a while.
Any ideas?
Hmm, seems some riders have the same problem.I have this friend who is an amazing bike electrical mechanic ( the best in this state)and put me onto new PVL coils ,also I was told put the plugs that the manufacturer recommends,which I have done .Fired it up left it over for a couple of days and just now fired it up again ,runs sweet.I'll take it for a blast this afternoon .I'll still replace the HT leads anyway as it gets mighty warm around that area,then if any problems the next will be a new igniter if all else fails.
 

·
Registered
Joined
·
8 Posts
I have a similar problem on my 96 Daytona 900 with 13k miles. Runs cleanly and idles fine all the time except when starting from cold on the choke.

It fires up first on one cylinder only, stumbles along and then a 2nd cylinder fires up. Then the idle jumps up as the 3rd cylinder fires up. Then it runs fine and you can pull away with no problem.

New plugs. Carbs cleaned and balanced and snug fit to the cylinder head. Valve clearances set. New battery and charging at 14v. Headlight is on a relay.

So not sure where to go next.........
 

·
Premium Member
Joined
·
13 Posts
Discussion Starter #8
Mate, try new PVL coils I have done everything too now starts and runs sweet ,on a warm day no choke .
 
1 - 9 of 9 Posts
Top