Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Greetings...I took delivery of a 2012 Tiger Explorer 1200 yesterday. This morning, I was trying to get to the Setup Menu to verify that the dealer had correctly set up traction control, ABS etc.

With ignition on and bike in N, the left handlebar 'i' button SHOULD scroll through:

Trip 1
Trip 2
Air Temp
Setup

However, it DOES scroll through:

Trip 1
Trip 2
Air Temp

...Setup Menu is unreachable. Engine kill switch position doesn't seem to matter...activating the "Home" button first doesn't matter. I called the dealer and they have no idea what's happening. Does anyone know the secret handshake?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #2
Postscript: 5 miles later.

When I got done with a quick ride, I could in fact get to the Setup menu. Also, the fuel gauge, which had presented as low, now was full. I can only guess the on-board computer just needed to gather more data before it could proceed?
 

·
Registered
Joined
·
978 Posts
Don't know if its similar but when I fill my R3R with fuel it takes a while to recognize it's full.

Sent from my GT-I9100P using Motorcycle.com Free App
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
the menu is only avalible when the bike is parked (stopped) and in NEUTRAL :D
As indeed mine was, in all cases (see OP). "Stopped and in neutral" is a necessary but not sufficient condition to reach the Setup menu.
 

·
Registered
Joined
·
52 Posts
The fuel gauge thing is normal. In the owners manual it will tell you that you have to ride for a bit after you fill the tank for it to update. I think it said something like it can take up to five minutes depending on your riding style.

I am not sure why you can't get to the setup menu. The stationary and in neutral should be all that is required.
 
1 - 6 of 6 Posts
Top