Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Greetings!

I have a ‘14 America LT that developed a strange rattle about a year ago that I can’t seem to pin down. I hear it mostly while decelerating with engine braking, but hear it at other times as well. It sounds like a can full of coins rattling around. Anyone have any experience with this, and found a solution?
 

·
Registered
Joined
·
2,154 Posts
Have not had a "can full of coins rattling around" sound. But I did have a muffler heat shield weld break and it took a while to track down the rattle/jangling sound.
Can you feel anything corresponding to the sound? Chain and chain guard noises come to mind.
Were there any maintenance activities last year? If so double check any fasteners that may have been involved.
Do you have accessories added like a windshield or luggage rack that would have fasteners not easily seen?

edit: Recent thread but no actual resolution from the twins area
https://www.triumphrat.net/air-cooled-twins-technical-talk/959868-need-help-w-mystery-rattle-clank-03-speedmaster.html
 

·
Registered
Joined
·
54 Posts
Rattle

I have a 2016 America doing the same. At 78 mph indicated, almost sounds like helmet visor rattling, but it’s not. It’s quite pronounced, but doesn’t effect anything....I’ll check my exhaust shields too.
 

·
Registered
Joined
·
1,147 Posts
I seem to recall a member who had some lose internals rattling in the exhaust.
But as mentioned check the heat shields.
Also check the small collar at the header connection, I've seen those break loose as well.
 

·
Registered
Joined
·
26 Posts
I had a similar noise on my 10 Speedmaster. Turned out to be the locking nut & washer on the engine sprocket was loose. Tightening and resetting the lock washer fixed it.
 
1 - 5 of 5 Posts
Top