Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am the proud owner of a Speed Four,
I have owned my SF for around a year and a half and have never had a problem with it. I recently had my brake pads and disc changed (rear wheel), after only 52miles both the pads and disc were unusable. Is this problem any one else has encounter (is there such a thing as faulty pads, to this extreme?), when the brakes were changed everything was given a good clean first so dirt isn't the issue. Do I have a larger problem with the bike, or should I just look for a new garage to do my work for me?

Help!
 

·
Premium Member
Joined
·
12,708 Posts
Welcome to the site.

I've never heard of that problem with the rear brake pad and rotor before. Sounds like they weren't properly adjusted when they were replaced. How much do you use your rear brake in 52 miles? I'd definitely question the mechanic who did the job.

Take a look around at the different forums and become familiar with them, especially http://www.triumphrat.net/triumph-supersports/

Also check out http://www.triumphrat.net/biker-hang-out/ where we have fun chatting about anything (except politics and religion ).

The AUP is here: http://www.triumphrat.net/faq.php?faq=trataup#faq_aup

Don’t be shy about posting! The only dumb questions are the ones we don’t ask.

You can modify your profile/favourite bike description, to include the year & model - this makes for instant identifier for others when you have questions.

As an international site members are also requested to fill in their location details of their profile, a city and/or country is preferred.

Each forum has a moderator to answer your questions about the running of the site and to solve any problems. If you need something lets us know.

Haggis
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
New brake discs and pads fitted, free of charge. 5miles and counting fingers firmly crossed.
 

·
Registered
Joined
·
1 Posts
I've had a triumph adventurer 1999 for about 6 years now. Today I Am trying to get her up and running after being in storage for about a year and a half. I moved into downtown Minneapolis and I had nowhere to park it so its been sitting in my dads back shed for the past year and a half collecting dust. She Won't Start...Sooooo I Found This Lovely Site. Hopefully, With All The Great Info I Can Get Her Going Without Having To Take Her In.
 
1 - 6 of 6 Posts
Top