Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 17 of 17 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I’ve replaced the cat on my 2019 water cooled T120 black with a lighter x pipe decat
I’ve also added Norman Hynde Toga pipes. I’ve experienced the engine light staying on along with some spluttering when throttling. Do I need a retune or an engine check by Triumph specialists? Thanks if you can help me
 

·
Premium Member
Joined
·
1,778 Posts
Any leaks? Similar stuff has been done on a Thruxton without really high A/F. I would think a new tune, like from DNK Tuneworks but I don’t see why you would get an engine light. I would get a Lonelec cable (in the UK), an android tablet, and buy TuneECU to read the fault codes. Then buy a tune from DNK and install with a TuneECU.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Any leaks? Similar stuff has been done on a Thruxton without really high A/F. I would think a new tune, like from DNK Tuneworks but I don’t see why you would get an engine light. I would get a Lonelec cable (in the UK), an android tablet, and buy TuneECU to read the fault codes. Then buy a tune from DNK and install with a TuneECU.
Thanks for the advice
 

·
Registered
2018 Bonneville T120
Joined
·
195 Posts
I have a Motone decat and Norman Hyde Togos. No light and no spluttering. Might you have damaged the O2 sensors or their wiring when you did the decat?

Chuck
 

·
Registered
Joined
·
538 Posts
Did you do the 12 minute adaptation procedure after fitting them?
The latest ECU update for the T120 came out October 2019, if your bike is newer than this there is no newer tune available.
 

·
Registered
Joined
·
538 Posts
When the bike is cold you simply start the engine without touching the throttle and allow it to run for 12 minutes after the fan kicks in - do not touch the throttle at all . once the 12 minutes are up turn off with the key and leave the ignition off (for a couple of minutes) to allow the ECU to save the new parameters. Hopefully this should sort things out although further adaptation will take place as the bike is ridden.
Any fault codes thrown up or a flashing spanner ?
 

·
Registered
Joined
·
538 Posts
IT should extinguish, that would normally indicate a fault. To check the fault code's ensure the kill switch is in the run position, press the "I" button on the left switch cluster and then turn the ignition on whilst continuing to press the I button, When DTC appears on the speedo LCD display release the I button and you'll either have P followed by either 0000 or a four digit fault code number. O2 sensor faults are usually P0030 P0032 P0050 P0052
 

·
Registered
Joined
·
538 Posts
What was the code?
 

·
Registered
Joined
·
538 Posts
Fault code not displayed due to Malfunction Indicator Lamp lit.
Normally disconnecting the battery for 15 mins would help and It wouldn’t lose any stored codes either. If that doesn’t sort it and then display a code if there is one it’ll have to be plugged in to diagnostics at a Triumph dealer :(
 
  • Like
Reactions: Haro
1 - 17 of 17 Posts
Top