Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1 (Edited)
Washed the bike (tried to avoid any direct spray towards the instrument panel) and oiled the chain. Took it off the center stand and now it won't start. I turn the ignition switch clockwise to "on" and get nothing; no lights, instruments, etc. I can't turn the switch counterclockwise to get to lock or park. Seems like the ignition switch suddenly failed. Has anyone seen anything like this before? Could it have anything to do with washing the bike or putting the center stand up and down?

It's under warranty so I called the dealer. They said I need to get the bike to them at my own expense, and since they're over 50 miles away I'd like to avoid the towing charge.

Any help would be appreciated.

Update: Tried the ignition switch again and now I can get it to move in both directions, but still nothing when I move it to "on".

Final Update: All is now working! Don't know if some water got in somewhere and then dried out, but I'm obviously relieved the problem seems to have disappeared.
 

·
Registered
Joined
·
7 Posts
push the key down? and then turn


Best answer for you is to call your breakdown company under homestart if you have it and they will sort you for nothing - if they can't fix they will take it to the dealer for you

Good Luck!
 

·
Registered
Joined
·
79 Posts
Discussion Starter #3
Thanks much. Got it going again so all is good for now. I'll have to look into homestart.
 

·
Premium Member
Joined
·
619 Posts
Sounds like the kill switch, or the wiring to the switch where it plugs into the loom. See what I mean, flip it off then try turning on the ignition.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #5
Sounds like the kill switch, or the wiring to the switch where it plugs into the loom. See what I mean, flip it off then try turning on the ignition.
You may have nailed it. Of all the things I did while fiddling around with it (turned ignition off and on, pulled and checked fuses, lifting kickstand up and down), toggling the kill switch a few times was maybe the last thing I tried before it started up. If it acts up again, that's the first thing I'll need to look at. Thanks very much.
 
1 - 5 of 5 Posts
Top