Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
On a ride, three miles from house, bike dies, gas but no apparent ignition. Tow home, battery measures weak so i replace the battery. Bike starts right up and I park it for a few days on a tender. Go for ride today, same thing. Three miles from house bike just dies like it has no ignition. No obvious shorts, burned fusses, or other signs of a short. Going out to test the battery, what else should I look for?
Thanks,Dave
 

·
Registered
Joined
·
582 Posts
On a ride, three miles from house, bike dies, gas but no apparent ignition. Tow home, battery measures weak so i replace the battery. Bike starts right up and I park it for a few days on a tender. Go for ride today, same thing. Three miles from house bike just dies like it has no ignition. No obvious shorts, burned fusses, or other signs of a short. Going out to test the battery, what else should I look for?
Thanks,Dave
If your battery is fine then perhaps it's an issue with your alternator. That or indeed your electrical circuit has a short/leak somewhere. Sorry for your trouble.
 

·
Registered
Joined
·
6 Posts
Hey Daveel,
Hope you sorted your issue but, if not, to diagnose the Alternator you can put a meter across the battery with the bike running. If the voltage is dropping then your alternator is not charging the battery. You probably already know that but there ya go.
 
1 - 5 of 5 Posts
Top