Triumph Rat Motorcycle Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
Occasionally when I decelerate in gear ill pull in the clutch and blip the throttle. Every now and then the bike makes a pop sound ranging from a backfire to the sound of a paddle hitting a ping pong ball. I thought it was from the back but I rode the bike without a helmet its definitely coming from the front. When I blip the throttle the bike pretty much bogs or dies for a hair of a second when the pop happens. So the engine stops firing, makes the pop sound, jerks a little, and fires right back up again. When the pop happens I can hear the throttle bodies actually slam shut due to absence of running sounds.

I'm wondering what it could be before I take it to the dealer, they can't recreate it and my time is wasted.
 

·
Registered
Joined
·
36 Posts
This happens to me as well, only in neutral or with the clutch pulled in (disengaged)
Though I just get a pop. Engine doesn't die or anything.
 

·
Registered
Joined
·
137 Posts
Discussion Starter · #3 ·
This happens to me as well, only in neutral or with the clutch pulled in (disengaged)
Though I just get a pop. Engine doesn't die or anything.
Identical to what happens to mine. No stall or die, I worded it weird. It's a hesitation. Just a backfire but through the intake when I blip the throttle.
 

·
Registered
Joined
·
4 Posts
I seem to be having a similar problem with my Bonnie. I have tried several solutions but have not been able to correct the problem. I even had to replace the rubber connecting hose from the throttle body to the head because it burst. Did you find out what the issue was?
 
1 - 5 of 5 Posts
Top