Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of September's Bike of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
I seem to be having intermittant starting problems. Happened a couple of times now. Seems to be either the clutch or side stand cut-out switches as I eventually got her started after fiddling with the switches.

Anyone else had similar issues or had to replace either switch?
 

·
Registered
Joined
·
1,023 Posts
had a problem with the clutch switch early on. one day when i was at the gas station the bike would not start back up. i beat the clutch lever with my fist and i have never had a problem since.
 

·
Registered
Joined
·
979 Posts
My bike will only start with the clutch lever about 10mm out from the handgrip,try starting it with your lever in different positions.Should get it replaced while it's still under warranty i guess but the closest dealer is well lets say,--------------------. :-D :hammer:
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #4 ·
On 2007-02-07 23:48, BUCKET wrote:
My bike will only start with the clutch lever about 10mm out from the handgrip,try starting it with your lever in different positions.Should get it replaced while it's still under warranty i guess but the closest dealer is well lets say,--------------------. :-D :hammer:
Thanks for the tip Bucket. Yeh I want to get it fixed before the warranty rund out too...
 

·
Registered
Joined
·
2,300 Posts
Mine will only start with the clutch in the "right" position...soon as it's not -5F with a few feet of snow I'll get it to the dealer. I would guess it's a vendor issue with the clutch switch, seems to be more failures than I would normally expect.
 
1 - 5 of 5 Posts
Top