Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Premium Member
Joined
·
312 Posts
Discussion Starter #1
Have very heavy varnish deposits all over the fuel pump/tank interior. Considering replacing the pump if soaking doesn't rehabilitate it-found a thread for replacing the oem pump with Bosch pump #69767. Question is: Is there an alternative to the Triumph supplied fuel filter? Has anyone tried this Bosch pump, does this include the strainer on the pump also??

Have recommendation for soaking in Diesel fuel and also Seafoam for the pump components-any thoughts as to what's preferrable??

THANX!!!
 

·
Premium Member
Joined
·
312 Posts
Discussion Starter #3
Okay Thanx, I will check it out!!

Varnish Deposits were real bad-worst I've seen and some of the fuel had jellied in the tank

Cleaned it all and then checked the pump operation with jumpers from a good 12v battery. All i can get is a single click. Should I be hearing the pump actally running?? THANX!!

S2300020-001.JPG

S2300022.JPG

S2300029.JPG
 

·
Premium Member
Joined
·
312 Posts
Discussion Starter #4
Thanx Cos!!

Just picked up the Napa filter with the hoses and clamps for just over $4 bucks!! Maybe i will be able to afford to get this Trumpet running after all...Still trying to mount the computer & the electrics w/o much success-been searching around for some photos of the under seat and beneath the tail plastics for ideas...DE'cosse recommended trying to mount the mc 1000 on the front of the battery box with the plugs pointing downwards...think i've got the battery box and that attached metal undertray in correctly and don't have enough room between the battery box front and the top of the shock??

THANX AGAIN!!:confused:
 

·
Premium Member
Joined
·
312 Posts
Discussion Starter #5
Okay-New Filter and hoses with old pump installed in tank, soaked in 15oz of Berryman's B-12 and 1 gallon of gas overnight and shook the tank periodically-The pump now turns on when attached to 12v jumper wires!!! Now onto struggling with that wiring harness and computer-STILL cant figure out where to mount everything!!!
 
1 - 5 of 5 Posts
Top