Triumph Rat Motorcycle Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Help! I've successfully overhauled this monster and ridden it for 100 miles, then the starter sprag clutch disintegrated. Bought new parts from England, and the new clutch froze in a misaligned fashion. I understand that these things are temperamental. Is there a real fix? The beast is just sitting there until I get the electric starter working reliably. Help!
Thanks,
Don
 

·
Administrator
Joined
·
19,460 Posts
Welcome to the forum!

The Classic, Vintage, and Veteran forum is where you can connect with other classic Triumph riders and rebuilders. The folks there will best be able to assist you. Introduce yourself there, post photos of your T140E, and join the banter.

http://www.triumphrat.net/classic-vintage-and-veteran/

Connect with local riders in the RAT forums. If you do not see a thread for your area, please start one.

http://www.triumphrat.net/rat-west/

http://www.triumphrat.net/rat-west/229958-san-diego.html

You may also find local riders and local events in the Rides and Events forum.

http://www.triumphrat.net/rides-and-events/

Please share your rides with us by posting photos of your rides in the Ride and Trip Reports forum.

http://www.triumphrat.net/ride-trip-reports/

Enjoy some off-topic and often humorous conversations in the Biker Hang Out forum.

http://www.triumphrat.net/biker-hang-out/

There is much to our forum, so please make yourself at home, browse the forums, and join the conversation where ever it may interest you. We are happy to have you here.

Cheers!
 
1 - 3 of 3 Posts
Top