Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi. I've come to a dead end. Can't quite figure out why my front blinkers both dimly light at the same time regardless of what direction the switch is. My brake light isn't lighting as well (brand new bulb.) Both issues seem to have occurred at the same time.

Anyone ever run into the same problem? Any suggestions would be greatly appreciated.

Thanks!
 

·
Registered
Joined
·
396 Posts
I'd start by tearing apart the turn signal switch and clean it up as best you can. check every electrical connection you can - when you re-connect them, put a glop of dielectric grease on it - it helps prevent future corrosion in the connection.

I just think you have some corrosion in the system somewhere.
 

·
Registered
Joined
·
1,825 Posts
Sounds like you've lost a ground. Check and clean. You might check the tail light to insure it is properly installed. I have seen them put in 180 degrees out (It's hard to do but I've seen it done).
 

·
Registered
Joined
·
601 Posts
Hi. I've come to a dead end. Can't quite figure out why my front blinkers both dimly light at the same time regardless of what direction the switch is.
Thanks!
Jfritts,

If the rear turn markers are bright, it will have to be either a
gound problem on the fronts or the lucar connectors in the
headlight shell. Just trace the wires from the markers into
the shell and you will find the connector.

As for the rear brake, does it not work with either the petal or
the hand brake?

Pookybear
 
1 - 4 of 4 Posts
Top