Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 20 of 119 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Hey guys, I have a 2020 street triple 765rs and have had the engine cut out three times now. The first time was scary as I was in a round about and the other times was when i was in a eighty zone. I'm thinking if I take it to the dealer , they're not going to find anything , but I will get it checked as it's getting dangerous now. Has anyone had this issue.
 

·
Registered
Joined
·
161 Posts
I had this once slowing down to park the bike on a slight downhill road.
Mine is a 2020 RS as well.
I was positive I had not done anything wrong.

I was going to see if it happened again, but haven’t been riding much due to the lock down.
 

·
Banned
Joined
·
1,207 Posts
I ask, because a lot of us have seen issues with the 2020 quickshifter... Where occasionally it simply doesn't work... it won't click and grab the next gear. Stands to reason that if some have an intermittent issue where they fail to cut spark... others might "stick" and cut the spark long enough to stall it?
 

·
Registered
Joined
·
602 Posts
I had 3 stalls within the first 500 miles or so. They were all under hard braking and using the clutch to downshift, while coming to a stop. It hasn't happened since and I am up to 1300 miles now. Think maybe the fueling needs some time to adapt and the engine to break in a bit. They make these things run very lean.
 

·
Registered
Joined
·
7 Posts
2019 RS here. I’ve had it cut out 4 times over 3,500 miles. Has happened 2 times coming off high throttle and 2 times with clutch pulled in at slow speed. Seems to happen when slowing down. Dealer checked it out for a few hours found nothing. Noticed some sulfation on the battery terminals so swapped out for a Shorai. I tried to make it stall in a parking lot in gears 1-3 and she won’t stall even with no throttle at a crawl so don’t think it’s fueling. Might need to check the charging system next but hoping they already checked that and maybe the quickshifter. One more year under warranty so hopefully can figure this out or selling her if it continues.
 

·
Registered
Joined
·
2 Posts
Hey guys, I have a 2020 street triple 765rs and have had the engine cut out three times now. The first time was scary as I was in a round about and the other times was when i was in a eighty zone. I'm thinking if I take it to the dealer , they're not going to find anything , but I will get it checked as it's getting dangerous now. Has anyone had this issue.
Yeah I’ve experienced this on both models of the new RS range. 2017 and new 2020 model. Usually 2nd gear clutch fully in, coasting.

Mu clutch assembly has been replaced on both models. (My new 2020 model has already hada full clutch assembly replacement -2000 miles - and now it’s happening again -3300 miles - Partial engagement but revs high and delivers no power. It will fail fully again and just Rev with no gear engagement.

anyboy else with similar issues?
 

·
Registered
Joined
·
14 Posts
Hey guys, I have a 2020 street triple 765rs and have had the engine cut out three times now. The first time was scary as I was in a round about and the other times was when i was in a eighty zone. I'm thinking if I take it to the dealer , they're not going to find anything , but I will get it checked as it's getting dangerous now. Has anyone had this issue.
I also have a 2020 765rs and I have also had the exact same event occur, three times over the last 3200km. In each case it was at low speed in either 1st or 2nd gear after shifting using the clutch. I spoke to my dealer and they had not heard of this issue. I will be taking it in shortly when I replace the tires, my dealer is 120km away. I am wondering whether it could be a faulty side stand switch.
 

·
Registered
Joined
·
1,154 Posts
Seems like we have two threads discussing the exact same issue.

 

·
Registered
Joined
·
2 Posts
I also have a 2020 765rs and I have also had the exact same event occur, three times over the last 3200km. In each case it was at low speed in either 1st or 2nd gear after shifting using the clutch. I spoke to my dealer and they had not heard of this issue. I will be taking it in shortly when I replace the tires, my dealer is 120km away. I am wondering whether it could be a faulty side stand switch.
Yeah it’s a little bemusing when it happens. Just cuts out without warning. Defo seems like an intervention as it just cuts the engine, dash is unaffected power wise.


I’ve had a few Issues with my RS’s from short wires on looms round the yolk, to clutch assembly’s going. I don’t not think it’s too out of line with other manufacturers..... And Triumph have always sorted it.....
 

Attachments

·
Registered
Joined
·
31 Posts
I was out Friday and mine cut out without warning. It's a 2020 with 500 miles on it when it happened. I'm running it in by the book so wasn't going at any speed. I was either going from second to third or fourth to third. I pulled the clutch, kicked the gear in to third and it died. Scared the crap out of me as I was on a back road and had to coast to a stop on an unsafe stretch. The dash stayed illuminated and I just held the clutch in and rolled to a stop (not sure what I should've done?) Called the dealer and had to add another 80 miles to my 120 mile jaunt so they could run the diagnostic. Nothing found and they told me not to worry about it - "we don't have any known issues with the new RS".

Thinking I've made a mistake with this bike:
  1. The front end - headlight assembly is wonky - points left.
  2. This cut out worries me - clearly I'm not the only one with an issue
  3. When I got home the reflector above the numberplate had gone - fallen off somewhere.
  4. Checked the coolant this morning and it's dropped below minimum
I'm beginning to think that the spiel about Triumphs attention to detail is just bollocks
 

·
Registered
Joined
·
31 Posts
When it stalls like that what's the correct thing to do? Do I have to roll the bike to a stop with the clutch pulled then turn off/on with the key and restart or is there another way to get it going again?
 

·
Registered
Joined
·
602 Posts
When it stalls like that what's the correct thing to do? Do I have to roll the bike to a stop with the clutch pulled then turn off/on with the key and restart or is there another way to get it going again?
I have restarted mine while rolling in gear with the clutch pulled in.
 

·
Registered
Joined
·
31 Posts
I have restarted mine while rolling in gear with the clutch pulled in.
OK thanks - that would've been the safer thing for me to do, but with the shock of hearing the engine go silent I just panicked I suppose. I'm not happy about it mind - could easily result in an accident.
 

·
Registered
Joined
·
1 Posts
Hey guys, I have a 2020 street triple 765rs and have had the engine cut out three times now. The first time was scary as I was in a round about and the other times was when i was in a eighty zone. I'm thinking if I take it to the dealer , they're not going to find anything , but I will get it checked as it's getting dangerous now. Has anyone had this issue.
Mine cut out as I was nearing an exit. I just reached 500 miles accelerated then slowed a bit then I think I down shifted it cut out . hit the start button and nothing. thank goodness nobody was talking me.
It was scary I was riding all day like 150 miles because I'm breaking her in and wanted to get to 500 for the first service.
Also, I've had it stall on take off then hit the start button and nothing.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #20 ·
Hey guys , there is a guy on YouTube who filmed his cutting out exactly like mine. Look up 2020 triumph street triple 765rs , filmed by funny motoman and at 11mins 30sec the first cut out happens, then 11mins 58sec the second will also cut out. With his bike they replaced ecu, crank case sensor, but the culprit was the stator. This is of great concern to all who own these bikes .
 
1 - 20 of 119 Posts
Top