Triumph Rat Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
So I was out riding the other day and everything was fine. Shut the bike off to run inside for a bit and came back out -- and it won't start. When I press the start button, the headlight and dash lights turn off (as expected), and I can hear what I think is the starter relay clicking, but there is absolutely nothing from the starter itself. Just silence.

Out of an abundance of caution I completely replaced the battery with a brand new (and tested) one. Same thing.

I was able to bump start the bike and it ran fine.

Thoughts? Nothing happened to "cause" this, so I am at a loss. Possible the starter just died on me?
 

·
Registered
Joined
·
2,975 Posts
Check the wiring for the ignition running by the headstock, a few 2011s seem to have similar issues to the previous models where the wires are too short and crack/break over time.

You can try moving the bars/forks back and forth lock-to-lock while pushing the starter and see if it starts when the wiring is in one position vs. another.
 

·
Registered
Joined
·
130 Posts
my 08' starter button housing was rotating around the bars and the wires were mashed against a bolt. Maybe your wires are crimped at the housing or possible poor contact at the starter button. Just a thought
 

·
Premium Member
Joined
·
1,124 Posts
Won't be the button, or the lights wouldn't go out. Does the fuel pump prime when the key is turned on? Silly, but have to ask - Kill switch in run position? I have done that before.
 
1 - 6 of 6 Posts
Top