Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Bike of the Month Challenge!
1 - 20 of 23 Posts

·
Registered
Joined
·
2,355 Posts
Discussion Starter · #1 ·
I just finished doing my Eastern Beaver H4 upgrade and removed my PCV from my bike. Rode it to work yesterday and it died like like the brain just quit. Everything went dead. After a few seconds, it would fire back up. Really annoying, though.
Let me tell you, when you roll on the throttle in 2nd and you are hanging on for dear life, you don't want it to die.lol Like a slingshot. Almost threw me over the handlebars.
Checked out the wiring at work and found the problem. My ECU was dangling off to the side. I didn't put it back in the holder when I put the battery back in. It was coming in contact with metal where it was hanging. Repositioned it back in the holder and no further issues. Alls well that ends well.
Damn, this site is boring.
Later and have a great day
:Devil3
 

·
Registered
Joined
·
690 Posts
Frank,
The previous two Moderators ran A LOT of folks off.
The one the site has now, Lee,
is doing everything to try to build the base back up,
but it took a hard hit.
I enlightened several folks to the other sites in times past,
where we could have a discussion without being reprimanded..
It's different here now, but it'll take awhile before this site is actually not thought of as the one everyone dreads....
Shame too because this is the first site people usually find,
because it's the first one to cater to the R3 community.
Time will tell whether the old mods brought it down,
or if it can bounce back to it's former glory.
I personally hope so, good history and a lot of tips here.
 

·
Registered
Joined
·
354 Posts
I spose the glory part is in our hands , yes? I dunno about former coz I haven't been here that long and fell like everybody is pretty groovy. Haven't had any problems so far.
There are probably too many bloody Aussies:D
I'm on order for my new k&ns and jardine and I can't wait to fit them up. I haven't really worked on motorcycles since my old bonnies , beezers and beemers in the 70s and 80s. The jappers, I always left to the shop mechanics; so it'll be an interesting time I think.
I'm looking forward to sharing my little journey with you guys knowing many have taken the trip before me and are much more knowledgeable than I.
 

·
Registered
Joined
·
702 Posts
The moderators must be o.k. if they still let fat frank hang out here. He has pissed eveybody eles off on the other forums and half of Houston. Frank you need to stop hitting the red switch on the right side of your handle bars. Thats not the go fast switch. Damn rookies.:D
 

·
Registered
Joined
·
2,355 Posts
Discussion Starter · #5 ·
The moderators must be o.k. if they still let fat frank hang out here. He has pissed eveybody eles off on the other forums and half of Houston. Frank you need to stop hitting the red switch on the right side of your handle bars. Thats not the go fast switch. Damn rookies.:D
You know, for some of the stuff I've done on our site, I agree with you.lol I got nailed for mentioning another site. Of all things.
Hey, maybe I should liven the Rocket site up a bit.:Devil3

BTW, notice when you post a thread here for help, everybody is gone. Then, instead of help, Ken pops up and has to talk crap about me. If he wasn't so big, I'ld go over to his house and slap him down.lol
Hope to ride with you again soon.
The Old Man
 

·
Registered
Joined
·
702 Posts
Frank, is your phone still working? You need to push the green button to talk in your phone. Try it some time.:eek:
 

·
Banned
Joined
·
557 Posts
If I had a nickel for every post I have read that starts out, I just finished my Eastern Beaver H4 upgrade....I would have a nickel.

After visiting their site, whats your opinion? I upgraded the H4 bulbs almost 5 years ago, this product generates more light using less voltage ok I get it. Did you cut and replace the connector? Are they too bright for city driving?
 

·
Registered
Joined
·
2,355 Posts
Discussion Starter · #9 ·
They are brighter, but not that much. The purpose is to take the heat out of the wire cluster at the ignition.
solved my problem.lol I redid everything even though it was right to start with. Still had the same problem. intermittent power failures. While in the wire birds nest in the front of the bike under the tank. I managed to unplug a connection and not get it back together completely. Connected it znd everything is ok so far.

If I had it to do over again, I would wait for the ignition to crap out and get a warranty job on it.
There really isn't any cons of doing the upgrade if you do it right.lol

Later
 

·
Banned
Joined
·
10,016 Posts
My fellow Rocket riders....I trust you all ...we are adults. I do not feel the need to be heavy handed. I think we all just want to ride our bikes and have productive discussions about riding and any issues with our bike. Furthermore this is and should be a resource for all of us. If anyone has issues or problems in regards to the forum...please let me know I will do my best to address it. Remember ride alot and ride safe...:D Thank you Lee
 

·
Banned
Joined
·
10,016 Posts
I just finished doing my Eastern Beaver H4 upgrade and removed my PCV from my bike. Rode it to work yesterday and it died like like the brain just quit. Everything went dead. After a few seconds, it would fire back up. Really annoying, though.
Let me tell you, when you roll on the throttle in 2nd and you are hanging on for dear life, you don't want it to die.lol Like a slingshot. Almost threw me over the handlebars.
Checked out the wiring at work and found the problem. My ECU was dangling off to the side. I didn't put it back in the holder when I put the battery back in. It was coming in contact with metal where it was hanging. Repositioned it back in the holder and no further issues. Alls well that ends well.
Damn, this site is boring.
Later and have a great day
:Devil3
Frank what the heck do you want...perhaps a long ride will make you less testy.....:D
 

·
Banned
Joined
·
10,016 Posts
Frank,
The previous two Moderators ran A LOT of folks off.
The one the site has now, Lee,
is doing everything to try to build the base back up,
but it took a hard hit.
I enlightened several folks to the other sites in times past,
where we could have a discussion without being reprimanded..
It's different here now, but it'll take awhile before this site is actually not thought of as the one everyone dreads....
Shame too because this is the first site people usually find,
because it's the first one to cater to the R3 community.
Time will tell whether the old mods brought it down,
or if it can bounce back to it's former glory.
I personally hope so, good history and a lot of tips here.
X thank you....I appreciate your support. Please let the others know they are welcome to return. this forum is not a problem.. I also appreciate the ability to resource my fellow Rocket riders. I am hoping the others will want to return...
 

·
Registered
Joined
·
702 Posts
My fellow Rocket riders....I trust you all ...we are adults. I do not feel the need to be heavy handed. I think we all just want to ride our bikes and have productive discussions about riding and any issues with our bike. Furthermore this is and should be a resource for all of us. If anyone has issues or problems in regards to the forum...please let me know I will do my best to address it. Remember ride alot and ride safe...:D Thank you Lee

Lee,

If Fat Frank gives you any trouble just let me know and I will handle it for you. He works to many hours and he is old. He gets like this when he misses his nap time.

kcc
 

·
Banned
Joined
·
10,016 Posts
Lee,

If Fat Frank gives you any trouble just let me know and I will handle it for you. He works to many hours and he is old. He gets like this when he misses his nap time.

kcc
K according to a 2011 study obesity can tied to lack of sleep. I suggest he gets more sleep and perhaps we will be refering to him as SkinyFrank....:D

Frank pm me if you have any suggestions on improving the forum...I am open to improvements..thanks Lee
 

·
Registered
Joined
·
2,355 Posts
Discussion Starter · #15 ·
Lee, forget the patch at the end.lol I have one of those (61). did you buy or earn the other 3 patches. Hurts my rear end to even look at the patches, let alone try to earn one. Has to be grueling on the backside to pull that off. Congrats on the achievments.
later and all is well.
 

·
Banned
Joined
·
10,016 Posts
Frank my 1000 miler was actually 1156miles in 20 hours straight..this time last year...in pouring rain and traffic for some of it at the start...I left Brazil Indiana at 0530 am and got to NM destination at 130 am....it was grueling, my total ride down from Maine was 2300 miles that time.

The 2000 miler was in less than two days from NM to NJ....the second day the hotels were calling to me as I road past them at 12 am at night....it was not easy.. the more fatigued I got the more I just wanted to pull over and sleep...

I am planning on a 1000 to get into shape in a couple of weeks in Texas. Then I am doing a 3000 miler in three days. Butt yes it gets sore...:D
 

·
Registered
Joined
·
2,355 Posts
Discussion Starter · #17 ·
Found the culprit. This connection is the problem. While bike was turned on and no power, I can move this connection and it will power up or quit. Tucked away right in the front. Is this the ignition problem people see o be having?
Thinking I wired my H4 relay bad, I redid it and my ATS which I extended.lol They were fine. Here is a ic of the connection. Anybody recognize it?
 

Attachments

·
Registered
Joined
·
702 Posts
Found the culprit. This connection is the problem. While bike was turned on and no power, I can move this connection and it will power up or quit. Tucked away right in the front. Is this the ignition problem people see o be having?
Thinking I wired my H4 relay bad, I redid it and my ATS which I extended.lol They were fine. Here is a ic of the connection. Anybody recognize it?

Frank, I think that is the wiring connector for the igintion switch. Some of the wires are the same color? If you are moving it, you may be moving the wires up by the switch and not know it. Check the under side of the switch and check.
 

·
Registered
Joined
·
2,355 Posts
Discussion Starter · #19 · (Edited)
Frank, I think that is the wiring connector for the igintion switch. Some of the wires are the same color? If you are moving it, you may be moving the wires up by the switch and not know it. Check the under side of the switch and check.
I was carefull not to disturb any other wires when I tried it last. I'm sure it is the wires to that connection.
Ken, I'm assuming that the wires go around to the ignition switch.
 

·
Registered
Joined
·
207 Posts
Frank,
The previous two Moderators ran A LOT of folks off.
Yeah that guy Diego just about ran me off but I stuck to my guns. He sent me about 5 different PMs telling not do this and not to do that. All I was doing was posting regularly just like I'm doing now..... nothing any different. I was new and just got my Triumph. I was telling myself "Man these Triumph people are total ***holes!"

But I found out that was not the case!! LOL
 
1 - 20 of 23 Posts
Top