Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all,

Pommy living in Melbourne, Australia here !!

I have a 2003 Sprint ST and am having a problem with the indicator flasher unit.
Basically, it has blown for the 3rd time in 3 months, each time costing $125......

Every time it has blown has been due to water, the first 2 times when I washed the bike, and last Friday due to rain.

I should mention that I just replaced the flasher unit last Monday, and then it rained on Friday and seems to have blown again.

When I replaced it last week, I coated the unit in silicon sealant and black electrical tape to try and protect it and it has blown again anyway.
Which leads me to think that the problem is not actually water getting directly into the flasher unit, but somewhere else.

Anyone got any ideas on how this may happen?
 

·
Registered
Joined
·
107 Posts
If it is the relay then you have a short along the wire somewhere, maybe closer to the indicators. I had this on prev bike. bought 2 relays from MCA ins syd ($12 each) until i found the wire that was touching the frame due to vibrations.


Good luck.
GK
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Its the actual flasher unit (not sure maybe relay) that sits inside the right side of the fairing.

As I said, theyre $125 each from a Triumph dealer so not sure if were talking about the same thing.....
 

·
Premium Member
Joined
·
24,383 Posts
Welcome mat out

Hi and welcome to the forum pommybloke:)

Don and I ask all noobs here to please read our forum stickies:)

I have an '04 and ride in the rain and all weathers and have never had a problem in 61,000kms so something is definitely not quite right there, but I can offer no advice I am sorry.:eek:

Enjoy the forum:)
DaveM
 
1 - 5 of 5 Posts
Top