Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
297 Posts
Discussion Starter · #1 ·
Went to start the bike the other day and would turn over but not fire up...Fuel issue...No relay click so I replaced it with a brand new relay for £22...HOORAY it clicks when I turn the ignition on but hold on I can't hear it priming..
Fuel pump as gone I thought so I bought a brand new one for £120 and banged that on thinking what a clever bloke I am but guess what...Still not priming...
Done continuity tests on fuses and the electrical connector on the fuel plate and all seems good...
The only thing I can think of now is to drain the tank remove the fuel plate and check if the electrical connector is actually providing power to the fuel pump when its actually joined together..
Any ideas and how likely is it that electrical connector is the issue???
747092
747093
747094
747095
 

·
Registered
Joined
·
2,265 Posts
I don't know very well the gen 1 but it seems there is a big connector called "engine connector" w/ a lot of pins between the ECU and the rest. Might be a good idea to inspect it. As it seems the pump + is connected to both the pump and the ECU, I guess the ECU reads the pump power. So I guess an error code would be triggered if no power to the pump. The ground seems to be switched directly by the ECU (no relay). Fuse 1 is the one that is used.

I guess others will have a better knowledge about the gen1.
 

·
Registered
Joined
·
252 Posts
My mate has a bike of similar vintage which sometimes spins happily but won't fire. It's the side stand switch-curiously they will still turn over but not fire. He puts the stand up and away it goes. Might be worth bridging the stand and clutch switches just in case. :)
 

·
Registered
Joined
·
12 Posts
Went to start the bike the other day and would turn over but not fire up...Fuel issue...No relay click so I replaced it with a brand new relay for £22...HOORAY it clicks when I turn the ignition on but hold on I can't hear it priming..
Fuel pump as gone I thought so I bought a brand new one for £120 and banged that on thinking what a clever bloke I am but guess what...Still not priming...
Done continuity tests on fuses and the electrical connector on the fuel plate and all seems good...
The only thing I can think of now is to drain the tank remove the fuel plate and check if the electrical connector is actually providing power to the fuel pump when its actually joined together..
Any ideas and how likely is it that electrical connector is the issue??? View attachment 747092 View attachment 747093 View attachment 747094 View attachment 747095
Went to start the bike the other day and would turn over but not fire up...Fuel issue...No relay click so I replaced it with a brand new relay for £22...HOORAY it clicks when I turn the ignition on but hold on I can't hear it priming..
Fuel pump as gone I thought so I bought a brand new one for £120 and banged that on thinking what a clever bloke I am but guess what...Still not priming...
Done continuity tests on fuses and the electrical connector on the fuel plate and all seems good...
The only thing I can think of now is to drain the tank remove the fuel plate and check if the electrical connector is actually providing power to the fuel pump when its actually joined together..
Any ideas and how likely is it that electrical connector is the issue??? View attachment 747092 View attachment 747093 View attachment 747094 View attachment 747095
I posted a similar problem a couple of months ago with my '01 Sprint RS. No Response from anyone yet. I too suspect problem lies with the Big Plug. A direct power connection from battery to fuel pump plug runs fuel pump just fine. Also, when I check voltage at fuel pump plug it reads close to 11v, but when plug back in turn on key, engine turns over fine, but does not start. I am going to try cutting plugs off and direct solder each. Will report back after complete this experiment.
Never give up!
 
1 - 4 of 4 Posts
Top