Triumph Rat Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
My 955's been running great since I got all the tank and fuel delivery problems ironed out (mostly thanks to DeCosse), which was about 8 months ago. Was in the garage, hadn't ridden in a couple of weeks--I do keep a batt tender connected. Went out for a ride with a nephew and at a stoplight a few miles into it, the idle got rough, and I had to rev a bit to keep from stalling out. Had no noticeable problems at speed, just the rough idle, and an intermittent noise, not a knock or a tick, but something in between, like one of the cylinders was misfiring. Figured I'd throw this up here and get some of the pros opinions before I take of the tank and dig in. I've yet to even hook up tune ecu to see if it can tell me anything.
 

·
Registered
Joined
·
1,799 Posts
If the misfire is occurring really often then it will trigger a fault code. But my experience tends to indicate the misfire must be very bad.
Keeping it simple I would first check the spark plugs and spray some contact cleaner or wd40 in the spark coils contact (bottom side/plug side).
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
If the misfire is occurring really often then it will trigger a fault code. But my experience tends to indicate the misfire must be very bad.
Keeping it simple I would first check the spark plugs and spray some contact cleaner or wd40 in the spark coils contact (bottom side/plug side).
Thanks for the quick response, Fredsprint. Going to pull the tank and plug and get a closer look when I get time this weekend. And hook up TuneECU for diag. Thanks.
 

·
Registered
Joined
·
98 Posts
Discussion Starter #4
So, finally had time and hooked up TuneECU this morning, bike started fine, idled fine, TuneECU diagnostics showed all is well. Thinking it might have been some bad gas? Will take it for ride sometime this weekend to see if problem resurfaces.
 
1 - 5 of 5 Posts
Top