Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,
Just bought a 1974 T140 and the battery is not charging.
1-Are there any tips or problem areas I need to look at first?
2- Does anybody have a wiring diagram for this year bike?
Thank you very much
Steve
 

·
Registered
Joined
·
6,533 Posts
You have a vintage bike. Best bet it to buy a both an OEM parts and repair manual. You can get them on ebay from Alan Fessler. He sends you a hard copy plus a digital copy on CD so you can print garage copies to get dirty. I only know him thru buying manuals from him. He's been helpful with tips and info as well.

Parts Manual
http://cgi.ebay.com/ebaymotors/Triu...022QQitemZ350162214027QQrdZ1QQsspagenameZWDVW

Repair manual
http://cgi.ebay.com/ebaymotors/Triu....c0.m245&_trkparms=72:727|65:12|39:1|240:1318

You might find them cheaper, but Alan gives you hard copy and CD and will also talk to you over the phone with help and tips. He loves Triumphs.

regards,
Rob
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
thanks

Thanks for the help, ordered the manuals. Trouble shot the problem to an incorrect regulator/rectifier.
I have a single phase alternator putting out 18-19 volts at speed and it appears somenody put a 3 phase regulator on it.
Ordered a single phase regulator/rectifier and hopefully that will fix it.
Thanks Pete for the tech data, very nice.
 
1 - 3 of 3 Posts
Top