Triumph Rat Motorcycle Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
No power to anything. Will not jump start so don't think it's the battery (plus battery was on trickle charge). No screen, no fuel pump sound. Any ideas?
 

·
Registered
Joined
·
115 Posts
Batteries can die at any time and a trickle charger won't do a thing if it is dead. It's rare for a new battery to go, but it happens.

Start with the easy stuff first. Take the battery to Autozone (or wherever) and have the battery tested.
 

·
Registered
Joined
·
12 Posts
I blew the ignition fuse (bottom one in the fuse box under the seat) once while installing my tail tidy. 10amp fuse. Probably what it is.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Batteries can die at any time and a trickle charger won't do a thing if it is dead. It's rare for a new battery to go, but it happens.

Start with the easy stuff first. Take the battery to Autozone (or wherever) and have the battery tested.
i know what you mean but unlikely as it wont jump start.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
I blew the ignition fuse (bottom one in the fuse box under the seat) once while installing my tail tidy. 10amp fuse. Probably what it is.


Sent from my iPhone using Tapatalk
Those fuses appear fine as does a big 30 amp fuse by the battery indicating green in its window. Nothing works. No lights, no fuel pump.
 

·
Registered
Joined
·
2 Posts
Try the ignition wiring at the headstock mine snapped due to how the wiring is routed a little to tight.
 

·
Registered
Joined
·
49 Posts
When was the last time you rode it? Have you ever had these issues on this bike in the past? Did anyone other than you ride it recently? Done any maintenance on it recently? Still have factory warranty?(If yes, take it in. Shouldn't have to deal with headaches on a new bike.)
 
1 - 10 of 10 Posts
Top