Triumph Rat Motorcycle Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
100 Posts
Discussion Starter #1
This is the second time I am having problems with my butterfly exhaust valve. The first time, it went out, followed by my main dash computer and as a result (not saying the butterfly valve was the problem) I had to change the whole wiring harness and other electrical components. Thank goodness for warranties. I don't know what is going on but it's going in AGAIN! I haven't dropped it, oil maintenance and everything like normal, just had the 6000mi tune-up 4 months ago. Dealer worked on always. All new electrical everything just about. Now this. Any clues on why this darn valve keeps going out? I mean really, second time in 5 months?!?!
 

·
Super Moderator
Joined
·
8,474 Posts
Cut out the entire section of exhaust and weld in a piece of straight pipe. I'm being a bit of a wise guy here, but I doubt most of us would notice if the whole contraption was missing.

Failing that, lube it periodically to keep it from seizing up, which is what sounds like might be happening to you.
 

·
Registered
Joined
·
100 Posts
Discussion Starter #3
lube it periodically to keep it from seizing up, which is what sounds like might be happening to you.
Actually, that sounds like what is exactly happening. I wish I could just totally disable the thing without cutting and welding a new piece of pipe! Im not totally with all the tools required to do the job so, any other suggestion?
 

·
Super Moderator
Joined
·
8,474 Posts
If you use the Arrow map, it's for an exhaust without the valve. I'm not sure how you would go about disabling it, but I suspect all you would have to do is remove the motor which makes it operate and then wire it open using some safety wire.
 
1 - 4 of 4 Posts
Top