Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys, nOOb here. Got a question for ya'll

Just bought my '03 Speedy last weekend.

Finally got out today for the first real ride other then slabbing it back home when I bought it. Love the bike but have a bit of a problem with the front brakes.

When I get on the brakes, I get a really pronounced pulsing and feedback from the front of the bike. It almost seems like the front end shakes back to front. Slow speed braking its not really noticable but under good solid braking its really kinda ****ed up feeling.

Pads are in good shape, actually look like they are pretty new. I don't see any visible distortion or waveiness in the rotors.

Any ideas.
 

·
Registered
Joined
·
728 Posts
Its possible your pistons are caked up w/ brake dust.
try pulling each caliper, removing the pads, spray with Brake parts cleaner then scrub with a toothbush.Re-spray. re-assemble and test.
let us know how you get on.
 

·
Super Moderator
Joined
·
22,109 Posts
Welcome Lakeguy556
If you have a moment please revisit your UserCP and enter your bike year/model in 'favourite bike' filed and also your location. These serve as ready identifiers appearing under your name in the left margin.
GDsila - you're obviously not new but would ask the same of you!

Back to normal programming:

Sounds like symptom of steering head bearings possibly!
 

·
Registered
Joined
·
453 Posts
I've ALWAYS had a squeal in my front brakes. Replaced all 4 pads this winter and thoroughly cleaned everything, still a squeal. Rotors bad?
 
1 - 6 of 6 Posts
Top