Triumph Rat Motorcycle Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Bike of the Month Challenge!

1 - 9 of 9 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
Just went to fire up my '02 ST for the first time in about two weeks. Got a slightly loud 'squeal' during the initial prime.

Before I hit the start button, I reenacted the pump for prime again.....same squeal. Once warmed and riddin' for a few miles, no more squeal.

Anyone have this happen and did your pump eventually fail?? Goin on a long trip and if it the coming of a potential-pump failure......I wanna replace it! :???:
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #2 ·
(I guess I should have noted.....a "Squeal" that my fuel pump has never done before. I have owned since new and the pump was allways barely noticible when primeing and <sound> non-existent when riding.)
 

·
Registered
Joined
·
924 Posts
Just some of the obvious questions:
1. Did you get any gas from an off the wall station lately? Some place that might have had a lot of junk in it?
2. Have you checked for a blocked fuel filter? Or maybe something clogging the fuel pickup in the tank?

I guess my first thought would be just to pull the tank and see what things look like inside.
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #4 ·
Naaa. I always use Amoco from the same dealer near me in everything I own (premium, of course).

And the fuel filter was just replaced mabey 8-9months ago. (or about 4200 miles)


Anyone use any kind of fuel injector cleaner in theirs without a prob?? And, what brand??
 

·
Registered
Joined
·
1,531 Posts
I wouldn't worry to much about it yet. Keep an eye on it. In '02 there were a batch of noisy pumps. They didn't hurt anything just annoyed people. And I think it turned out to be the regulators and not the pumps too.

I run fuel injector cleaner about once a year. Make sure you dose it right! Can't use a whole bottle in a 5 gallon tank. I also put in about an ounce of Marvel Mystery Oil in about once a month. Have not had any issues doing either.
 

·
Premium Member
Joined
·
4,389 Posts
Noisey (pressure regulators) were something my dealer told me about when I first bought my bike. Never a recall but if a customer complained about it the dealer would install a new one. Probably a little late for you but FYI the pressure regulator on mine is one of these take offs that we upped the pressure on at the 500mile service and hasn't been any problem since. It does squeal on initial priming but that's about it. I'd say it shouldn't be a problem.

I do about the same as Stlakid. About 1/2 oz. acetone and MMoil about every third tank full.

Don

[ This message was edited by: dolson on 2006-11-16 09:18 ]
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #8 ·
On 2006-11-15 13:06, tojohn wrote:
Naaa. I always use Amoco from the same dealer near me in everything I own (premium, of course).

And the fuel filter was just replaced mabey 8-9months ago. (or about 4200 miles)


Anyone use any kind of fuel injector cleaner in theirs without a prob?? And, what brand??

Just took her out today and she didnt do it! Guess I should also add that my bike just turned 16,000 miles...and never did this before now.

What do you guys add the Marvel Mystery Oil for?? Never tried that one!

(thanx for all the input!)
 

·
Premium Member
Joined
·
4,389 Posts
Marvel is one of the OLD snake oils that really work. It's been around for decades. Kind of an all purpose. I use a little mainly to keep the injectors and the intake valve and stem seals lubed. It's also good for and works better IMO for air tool lube.
I go this way because I can buy a years worth of "cleaner/injector lube" for all my rigs for the price of a couple of bottles of the canned off the shelf stuff.

Like KROIL for Kano Labs. it's pretty good stuff.

Don
 
1 - 9 of 9 Posts
Top