New to forum with problems with bike - Triumph Forum: Triumph Rat Motorcycle Forums
The Welcome Center New to the Site? Please take a moment to introduce yourself. New members and members who have yet not posted MUST post their first post here to activate their profiles.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-25-2010, 01:26 AM Thread Starter
Production 125
Main Motorcycle: 2004 Triumph Daytona
New Member
 
Join Date: Dec 2010
Location: Houston, Texas
Posts: 7
New to forum with problems with bike

New to this forum and have owned a 04 Daytona for about a year and some change. I'm having some electrical problems with it being grounded and want to get information on how to fix the problem. Bike wont start but will run if I jump it. Somewhere on the bike it is being grounded and going to start to search it out. Broke the damn flimsy fuel quick connects on the tank plate trying to take it off so bought new metal ones. Names Chris btw.

chrmiller1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-25-2010, 01:29 AM
Site Supporter
Supernova
Main Motorcycle: Speed Triple
Lifetime Premium
 
Catenaccio's Avatar
 
Join Date: Feb 2005
Location: South East Nevada
Posts: 24,197
Other Motorcycle: CBR1100XX
Extra Motorcycle: Piaggio MP3
Garage
Welcome Chris. Sorry to hear your Daytona is giving you problems. Intermittent shorts are a royal PITA.
You may want to visit the Daytona Deliberations forum under the Sport and Touring section. Good luck!
Catenaccio is offline  
post #3 of 3 (permalink) Old 12-25-2010, 01:52 AM Thread Starter
Production 125
Main Motorcycle: 2004 Triumph Daytona
New Member
 
Join Date: Dec 2010
Location: Houston, Texas
Posts: 7
Thank you sir. Yea I am searching everywhere looking for how to find the short.
chrmiller1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
New to forum with electrical problems TDwhite The Welcome Center 5 03-07-2011 10:08 AM
2nd bike, 1st forum GRST The Welcome Center 1 04-23-2010 11:43 AM
Forum access problems w/Comcast/Wireless? UJMrider Community Help 3 01-15-2009 02:02 PM
Bike Quit,Forum BIG help! DEN Maintenance & Workshop Talk 2 07-07-2004 11:33 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome