K & N pods - Triumph Forum: Triumph Rat Motorcycle Forums
The Welcome Center New to the Site? Please take a moment to introduce yourself. New members and members who have yet not posted MUST post their first post here to activate their profiles.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-07-2010, 06:10 AM Thread Starter
Newbie
Main Motorcycle: triumph speedmaster 06
New Member
 
Join Date: Apr 2010
Location: perth australia
Posts: 3
K & N pods

Hi people, just bought a 2006 triumph speedmaster, love it. Has western bars Madas pipes, single seat bullet ind lights etc. Looks the part. Just took it for a 100 k ride. Loved it more. However, I THINK I felt it lose power a few times (or was that just buffetting wind) at about 100 to 110Kph. It felt like it was starved for fuel or getting too much air or was it the strong head wind? It has 125 carby jets fitted at new with K & N pods any clues
putty is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-07-2010, 10:03 AM
Site Supporter
Nova
Main Motorcycle: '03 Daytona 955i
Lifetime Premium
 
HiDesert's Avatar
 
Join Date: Sep 2005
Location: Northern New Mexico, USA
Posts: 17,294
Welcome to the site, putty! Buffeting winds make it hard to judge that sort of thing. Find a nice calm day and repeat the 'test.'




I won't stop riding because you tell me about someone who died in an accident, just as I won't stop eating because someone died of e.coli.

HiDesert's ride photos
HiDesert is offline  
post #3 of 5 (permalink) Old 04-07-2010, 11:09 AM
Site Supporter
Supernova
Main Motorcycle: Speed Triple
Lifetime Premium
 
Catenaccio's Avatar
 
Join Date: Feb 2005
Location: South East Nevada
Posts: 24,197
Other Motorcycle: CBR1100XX
Extra Motorcycle: Piaggio MP3
Garage
Welcome putty! Try going downwind too. Runs in both directions will give you a better comparison.
Catenaccio is offline  
 
post #4 of 5 (permalink) Old 04-08-2010, 05:31 AM Thread Starter
Newbie
Main Motorcycle: triumph speedmaster 06
New Member
 
Join Date: Apr 2010
Location: perth australia
Posts: 3
Thanks guys, will give it a try as you say.
putty is offline  
post #5 of 5 (permalink) Old 04-08-2010, 09:26 AM
Site Supporter
Legend
Main Motorcycle: Tiger 955i
Lifetime Premium
 
Haggis's Avatar
 
Join Date: Sep 2003
Location: Alberta, Canada
Posts: 12,708
Other Motorcycle: Sprint RS
Extra Motorcycle: Honda XL250
Garage
Haggis is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
K&N Style Pods to Uni Pods = Rejet? rps_23 Air Cooled Twins Technical Talk 13 05-07-2011 10:57 AM
PODS.... Help Hitcher T3 Sport / Touring Forum 14 10-25-2009 10:36 PM
These new pods rodburner Air Cooled Twins Technical Talk 24 09-15-2007 10:50 PM
K&N pods on black? dazco Air Cooled Twins Talk 4 08-19-2007 04:37 PM
Mods&Pods Sport T3 Sport / Touring Forum 0 07-09-2002 11:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome