Triumph Rat Motorcycle Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-5 of 5 Results
  1. Speed Triple Forum
    I believe I have figured out what was causing my intermittent Battery system fault > Transmission Fault issues that started recently. So, this thread is just to put out what I believe should fix the issue. I did do some searching and this fix was mentioned, but I wanted to title and tags to be...
  2. The Welcome Center
    I have a 1979 Bonneville t140E with 11,000 miles on the clock. After riding it for a few hundred blissful miles, it refused to kick over one day - like solid, up-against-the wall would not move! The clutch had been a bit sticky since I bought it, engaging the rear wheel on the center stand in...
  3. Speed Triple Forum
    Hi all! Sadly, I've had a major problem as I was doing my break-in. I did the first 300 miles according to the break-in sticker- never going above 5k rpm. But after speaking with my local Triumph tech, I did 300-450 miles fairly hard; I was going all through the rev's and pushing quite a bit...
  4. Speed Triple Forum
    I've just extracted the engine in my '09 S3 for the second time, and I'm about to open up the cases for the first time. Someone decided to snack on a gear about 1000 miles after I had last removed the engine... I swapped out the timing chain on my last removal since I had about 60k miles on...
  5. Air Cooled Twins Technical Talk
    Hi all, So I've found a thread previously on someones gears getting stuck (The shifter just doesnt move up or down) and the "solution" was to roll the bike back six inches or so, roll it forward and try again, which works most of the time. The problem is it happens fairly regularly and I'd...
1-5 of 5 Results
Top