Back to a Speed triple - Triumph Forum: Triumph Rat Motorcycle Forums
Speed Triple Forum Rants and ravings about the best naked triple on the planet!

 1Likes
  • 1 Post By Jaip
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-31-2019, 05:07 PM Thread Starter
Minitwins
Main Motorcycle: Speed triple 955i 2003
New Member
 
Jaip's Avatar
 
Join Date: Sep 2017
Location: Grantham lincolnshire
Posts: 16
Garage
Hi all, had a speed triple 955i 2003 in 2017 and loved it, however due to wanting to tour I sold it and bought a sprint 1050, now the sprint was a nice bike but I never really bonded with it like I did my speed triple. So the sprint was sold and I’ve just purchased a 2004 speed triple 955i limited edition (black on black frame) I scrimped and saved and bought what I thought was the best I could get with my budget. There is a twist... bear with me lol. Anyhow, collected the bike last Friday at 5:30, at 5:45 I had broken down on the A1 waiting for recovery. Bike recovered and taken home.... lucky for me I bought from a garage and the cane and collected the bike next day to sort the problem, the bike starts fine, but as soon as you open up the throttle it dies, my initial thought fuel.

Garage calls me today to advise they believe the stator is the problem and have sent it away for repair by a company called West Country windings, they have advised that the stator, the Rev/rec and some other parts I’ve forgotten will be replaced at a cost of £400, all covered by the garage. Apparently to rebuild the stator is a weeks turnaround so roll on next week.

So glad I didn’t buy private

Speed triple 955i 2003 silver

Last edited by Jaip; 07-31-2019 at 05:09 PM. Reason: Predictive text
Jaip is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-31-2019, 07:04 PM
Site Supporter
Supernova
Main Motorcycle: Custom 955 Speed-Tona
Super Moderator
 
DEcosse's Avatar
 
Join Date: Feb 2005
Location: Pleasanton CA
Posts: 21,085
Garage
Welcome back to the fold!

It always troubles me when I see the word they "believe" it to be the stator .........
that doesn't exactly inspire me with confidence

Besides ............ if the engine cranks fine (is not laboured or slow) then there is nothing wrong with the stator - and with a healthy battery, you can disconnect the charging system completely and it will still run (at least until the battery discharges - however if there is enough juice to star it, it certainly would suggest enough power for it to run and not die as soon as you apply throttle!)

I wouldn't bank on getting your bike back in a week ...........

p.s. Signature of a failed generating system on your bike:
First indication is that your speedo will go to zero, especially at low engine rpm;
next, unless you keep the revs up, it will die - most likely to conk out when approaching a stop or light or similar
and finally, once engine dies, there will certainly be insufficient voltage/current for it to be able to crank.

If you bike did not exhibit any/all of the above, it most certainly is NOT the stator.
DEcosse is online now  
post #3 of 6 (permalink) Old 08-01-2019, 05:14 AM Thread Starter
Minitwins
Main Motorcycle: Speed triple 955i 2003
New Member
 
Jaip's Avatar
 
Join Date: Sep 2017
Location: Grantham lincolnshire
Posts: 16
Garage
Thanks Decosse, none of the symptoms above were present so looks like it could be an expensive waist of time for them. My initial thoughts were (apart from setting it on fire) fuel.... pump/filter/pipes/connectors etc but as it’s covered under warranty i’ll Leave them to it.

Will keep this updated

Speed triple 955i 2003 silver
Jaip is offline  
 
post #4 of 6 (permalink) Old 08-07-2019, 03:09 PM Thread Starter
Minitwins
Main Motorcycle: Speed triple 955i 2003
New Member
 
Jaip's Avatar
 
Join Date: Sep 2017
Location: Grantham lincolnshire
Posts: 16
Garage
Update...... stator was sent away and tested ok, tank stripped, fuel filter changed, fuel tank/pump/pipes injectors cleaned fault found with reg/rec so that’s also been renewed. Apparently all running ok now so bike being dropped back off tomorrow so fingers crossed all will be well. I’ll certainly be giving it a good run before I let them go.
Speedy Russ likes this.

Speed triple 955i 2003 silver
Jaip is offline  
post #5 of 6 (permalink) Old 08-07-2019, 06:00 PM
Site Supporter
Supernova
Main Motorcycle: Custom 955 Speed-Tona
Super Moderator
 
DEcosse's Avatar
 
Join Date: Feb 2005
Location: Pleasanton CA
Posts: 21,085
Garage
Quote:
Originally Posted by Jaip View Post
Update...... stator was sent away and tested ok,
No surprise there ...........

Quote:
... fault found with reg/rec so thatís also been renewed.....
Not buying that for same reason - 'someone' seemed determined to 'think' this was a generating system problem so when it wasn't the stator replaced the R/R
Still - not your money so you got new parts.

Hopefully the problem was indeed in the Fuel system and you can ride trouble free.
DEcosse is online now  
post #6 of 6 (permalink) Old 08-08-2019, 02:29 PM Thread Starter
Minitwins
Main Motorcycle: Speed triple 955i 2003
New Member
 
Jaip's Avatar
 
Join Date: Sep 2017
Location: Grantham lincolnshire
Posts: 16
Garage
Bike back and running fine now, thanks for the input and advice
Jaip is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome