2019 S3 RS - Front right indicator fault - Triumph Forum: Triumph Rat Motorcycle Forums
Speed Triple Forum Rants and ravings about the best naked triple on the planet!

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-28-2019, 11:38 PM Thread Starter
Minitwins
Main Motorcycle: 2012 Triumph Speed Triple
New Member
 
syne7's Avatar
 
Join Date: Aug 2012
Location: Cedar Park, TX
Posts: 11
Garage
2019 S3 RS - Front right indicator fault

My new S3 immediately started out wth:

Front right Indicator Fault
Check manual

Got my bike on a Saturday and dealer is not open till tomorrow. Will be calling first thing in the morning.

Blinkers seem to work.

Anyone experience anything like this? I have not found anything searching the manual pdf file.

----------
2019 Triumph Speed Triple RS
syne7 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-29-2019, 07:37 AM
Formula Extreme
Main Motorcycle: 2016 Speed Triple R
Senior Member
 
Nicspeed's Avatar
 
Join Date: Mar 2011
Location: Miami Beach, FL
Posts: 827
Garage
Welcome and congrats! It’ll probably clear out in a few heating cycles. It’s the electrical gremlins giving you the proper welcome. Yes, they are annoying, they are free, and we all triumph owners have to achieve special meditation skills to not set on fire our precious machines since the rising quality outweighs these critters.
Soaking that in... targeting this new-to-me gremlin...
Did you have the dealer swap the signals for the LED ones? Or maybe they weren’t working and they just replaced it? (They probably didn’t mention it if that’s the case) If so, when installing the signal they could've turn the key on at some point and the ECU detected a missing turn signal or touching cables (shorting) that might’ve triggered the code and will self cancel after it keeps confirming there’s no shorting or open terminals.
Nicspeed is online now  
post #3 of 6 (permalink) Old 07-29-2019, 10:21 AM Thread Starter
Minitwins
Main Motorcycle: 2012 Triumph Speed Triple
New Member
 
syne7's Avatar
 
Join Date: Aug 2012
Location: Cedar Park, TX
Posts: 11
Garage
Thank you very much. I appreciate the insight. I will check the signals.

----------
2019 Triumph Speed Triple RS
syne7 is offline  
 
post #4 of 6 (permalink) Old 07-29-2019, 10:28 AM
Formula Extreme
Main Motorcycle: 2016 Speed Triple R
Senior Member
 
Nicspeed's Avatar
 
Join Date: Mar 2011
Location: Miami Beach, FL
Posts: 827
Garage
Well, you say they’re working fine, so you don’t really have to check anything. Like I said the ECU will clear the fault in a few heating cycles if there’s no problems with it.
Nicspeed is online now  
post #5 of 6 (permalink) Old 07-29-2019, 01:54 PM Thread Starter
Minitwins
Main Motorcycle: 2012 Triumph Speed Triple
New Member
 
syne7's Avatar
 
Join Date: Aug 2012
Location: Cedar Park, TX
Posts: 11
Garage
Sorry, I meant check to see if they've been replaced with LEDs.

----------
2019 Triumph Speed Triple RS
syne7 is offline  
post #6 of 6 (permalink) Old 07-29-2019, 01:56 PM Thread Starter
Minitwins
Main Motorcycle: 2012 Triumph Speed Triple
New Member
 
syne7's Avatar
 
Join Date: Aug 2012
Location: Cedar Park, TX
Posts: 11
Garage
Whoever assembled the bike did not set up the date & time etc... which caused an alert when I set them. Not sure it was looked over with a detailed eye .

----------
2019 Triumph Speed Triple RS
syne7 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome