98 t509 cutting out at idle- when warm - Page 2 - Triumph Forum: Triumph Rat Motorcycle Forums
Speed Triple Forum Rants and ravings about the best naked triple on the planet!

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 (permalink) Old 04-30-2019, 10:09 AM Thread Starter
Grand Prix 125
Main Motorcycle: 97 speed triple
New Member
 
greenwood's Avatar
 
Join Date: Mar 2016
Location: Raleigh NC
Posts: 27
Garage
You are right! I unplugged the TPS accidentally for that one air box hose near it for the iacv. whoops

I balanced the throttle bodies off the left one (thanks guys).

The bike starts and runs well now.

Not a perfect idle but much much better and revs without missing, like my previous t509 97 that I had.

Thanks again everyone!

Last edited by greenwood; 04-30-2019 at 10:21 AM.
greenwood is offline  
Sponsored Links
Advertisement
 
post #12 of 13 (permalink) Old 04-30-2019, 10:46 AM
SOTP Vintage Series
Main Motorcycle: '98 T595 Daytona
Senior Member
 
Join Date: Mar 2011
Location: Northern NJ US
Posts: 7,011
Other Motorcycle: 2014 Ninja 1000ABS
Good for you. I would never categorize the idle of these older triples as ever perfect.
Felony is online now  
post #13 of 13 (permalink) Old 05-08-2019, 03:18 PM Thread Starter
Grand Prix 125
Main Motorcycle: 97 speed triple
New Member
 
greenwood's Avatar
 
Join Date: Mar 2016
Location: Raleigh NC
Posts: 27
Garage
if it misses again ill check the valves I rode it around for a little and it was nice and peppy!

98 t509 roulette green raleigh, nc
greenwood is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
t509 stalling at idle triplerock Speed Triple Forum 7 08-27-2015 10:28 AM
06 America cutting out when warm kent01 Cruisers - America, Speedmaster 15 02-05-2015 03:26 PM
Idle and jetting issues on carb 790cc msomerstein Air Cooled Twins Technical Talk 16 05-27-2013 12:15 AM
Rough Idle after warm up mjs3350 Speed Triple Forum 2 06-08-2011 08:45 AM
T509 High Idle matic00 Speed Triple Forum 4 05-15-2011 12:51 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome