Broken Speedo Sender Fix / Also mod for 05+ wheels on Early model - Page 25 - Triumph Forum: Triumph Rat Motorcycle Forums
Speed Triple Forum Rants and ravings about the best naked triple on the planet!

 11Likes
Reply
 
LinkBack Thread Tools Display Modes
post #241 of 243 (permalink) Old 04-11-2019, 09:38 AM
Grand Prix 250
Main Motorcycle: Speed Triple '03
Member
 
Russ's Avatar
 
Join Date: Aug 2008
Location: Perth, Australia
Posts: 76
The 3d print would have been paused mid print, had magnets placed in recesses and then continued : )

TOR, LiFePo4, 07 seat & subframe, 847 R/R, leds
Russ is offline  
Sponsored Links
Advertisement
 
post #242 of 243 (permalink) Old 04-11-2019, 06:00 PM
SuperSport
Main Motorcycle: '08 Sprint ST
Senior Member
 
sussurf's Avatar
 
Join Date: Nov 2009
Location: Sydney, Australia
Posts: 1,371
Other Motorcycle: '06 Daytona 955i
Extra Motorcycle: Husqvarna Terra 650
Garage
Send a message via Skype™ to sussurf
How bizarre, I was only reading this thread last week and my Daytona's speedo started playing up.
It would read accurately up to about 35km/h then go to single digits after that.
I pulled the front wheel and sure enough found the magnet in 2 pieces. Luckily I had a spare. It was a bit rough and looked like it had been repaired but I thought I'd try it anyway. It works fine!
So I epoxied my broken one last night and hopefully that can be my new spare!

cheers,

Phil
sussurf is offline  
post #243 of 243 (permalink) Old 04-16-2019, 01:44 PM
Grand Prix 500
Senior Member
 
Mashers's Avatar
 
Join Date: Jan 2019
Posts: 103
We I can report that the 3D print jobby works great. Now see if it stands the test of time.
SCHIM955I likes this.
Mashers is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!! speedo not working - Early Model 2005 Sprint ST reay21 Sprint Forum 1 02-10-2009 04:09 PM
early model Bonnie clutch tools? uzidzit Air Cooled Twins Technical Talk 10 04-24-2008 10:47 AM
Early Heated Handgrips On Later Model? Roverdrive T3 Sport / Touring Forum 2 02-29-2008 08:27 AM
Gripster now available for early model S3s! whodkne Speed Triple Forum 6 09-18-2007 12:57 PM
Sender wire for speedo ST05 Stik Sprint Forum 7 07-12-2005 10:47 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome