Triumph Forum: Triumph Rat Motorcycle Forums - View Profile: squariel
Grand Prix 250

squariel squariel is online now

Member

  About Me

  • About squariel
    Biography
    retired teacher of mechanical technology
    Location
    toronto ontario
    Interests
    motorcycle restoration, aircraft etc.
    Your First Name
    Keith
  • Motorcycles
    Main Motorcycle
    Triumph Thruxton

  Statistics

Total Posts
General Information
  • Last Activity: 06-17-2019 05:48 AM
  • Current Activity: Viewing Forum Classic, Vintage & Veteran
  • Join Date: 01-02-2016
  • Referrals: 0

  Mentions

No results to display...

  Quotes

05-01-2018
12:27 AM - drkblusea quoted squariel in post Exhaust cam bushing area damage?
I would not ignore it. These...
12-31-2017
07:56 AM - StuartMac quoted squariel in post Fitting 5K Resistor Plug Caps on the T140?
Hi, The coil voltage readi...
06:05 AM - StuartMac quoted squariel in post Fitting 5K Resistor Plug Caps on the T140?
Hi, tested the Lucas coils a...
10-16-2017
10:22 PM - Tornado99 quoted squariel in post Why so hard for Canadians?
I have ordered parts from Mot...
05-07-2017
09:26 PM - tjkoko quoted squariel in post 72 Triumph Trophy - running rough after winter
............I know that some ...
04-27-2017
08:08 AM - Truckedup quoted squariel in post T150 Main bearing caps switched
Its quite simple really, bear...
04-26-2017
11:48 AM - Tricky-Dicky quoted squariel in post ..positive oil filter.
The mass (weight) of 1/2 pint...
02:39 AM - StuartMac quoted squariel in post T150 Main bearing caps switched
Hi Mitch, Found that the m...
03-29-2017
08:37 PM - StuartMac quoted squariel in post 250 and 441 Interchangeable Parts
Hi, parts book for both an...
03-18-2017
08:21 AM - ukzknos quoted squariel in post Can't adjust out the slack on a throttle cable
...poor fit. Thanks Squariel, could you give me m...
03-16-2017
07:00 PM - suzyfan quoted squariel in post 69 fork assembly: I must be really thick. . .
The fork slider had the top p...
03-15-2017
07:59 PM - suzyfan quoted squariel in post Missing "O" rings! :-(
I have had the same problem r...
 
For the best viewing experience please update your browser to Google Chrome