Chasing a gremlin - Triumph Forum: Triumph Rat Motorcycle Forums
Daytona675 Forum D675 Riders and Enthusiasts

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 04-27-2019, 05:05 PM Thread Starter
Newbie
Main Motorcycle: '12 675R
New Member
 
Join Date: Apr 2019
Location: Arlington, Va
Posts: 2
Chasing a gremlin

I have been trying to track down what is wrong with my '12 675R for a while now, and for the life of my cannot figure out what it might be... Battery strong at over 13v

The only thing that I can get to work is the tach sweep when I hook the battery up.

Symptoms when I turn the key:
- No tach lights, display, nothing...
- Rear tail light dim

Some weird things (maybe? I loathe electrical issues...):
- Tail light gets brighter when the kill switch is flipped to kill
- Flipping either turn signal gives me hazards out back

What I've tested so far:
- Battery
- R/R
- Stator
- All fuses, replaced

Also, I've unplugged the the kill switch from the main harness which leads to a normally running bright tail. I've unplugged the tip over sensor by the dash, checked the clutch sensor, taken the tuner off, and don't know where else to go after now.

Am I dealing with a failed key/ignition cylinder, or some short around there? I have tried to search for similar problems, but everyone else seems to have some sort of dash or some other power.
grilledpineappl is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-29-2019, 01:18 PM
Site Supporter
Commentator
Main Motorcycle: Very fast 675
Official Leathers Tester
 
Will's Avatar
 
Join Date: Jan 2002
Location: Seattle, WA
Posts: 8,448
Other Motorcycle: DRZ 400 Bad Idea
Extra Motorcycle: Mad Max the Husqvarna
Did somebody scramble up the wiring at some point? It sounds like the wiring harness is a mess. If it hasn't been rewired by a teenager after his first round of way too much beer, then look for chafed wires. It's hard to plug in the connectors in the wrong place, but that is about all else I can think of. It doesn't sound like the usual charging system problems.

Will
It's a squid thing. You wouldn't understand.

Go soothingly on the grease mud, as there lurks the skid demon.
Will is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Chasing a Gremlin mrmach Air Cooled Twins Technical Talk 5 06-28-2016 04:14 PM
Now I'm frustrated AND broke - chasing 1 dead cyl gremlin JRobyn Hinckley Classic Triples 17 10-22-2014 07:36 PM
Electrical Gremlin Stratofaster Thunderbird Twin - Technical Talk 6 08-15-2014 04:17 PM
Gremlin bell doesn't work brolane T3 Sport / Touring Forum 6 06-29-2009 10:02 AM
Gremlin Bells? Mine saved me jeffro Sprint Forum 26 02-12-2008 04:56 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome