‘15 D675R Slip On - Triumph Forum: Triumph Rat Motorcycle Forums
Daytona675 Forum D675 Riders and Enthusiasts

 1Likes
  • 1 Post By Mr_nobody
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-11-2018, 05:49 PM Thread Starter
Newbie
New Member
 
Join Date: Oct 2018
Posts: 4
‘15 D675R Slip On

I just installed an SC Project slip on and went to the dealer to get the slip on map installed. I had to remove the servo motor, which threw a CEL.

The new map got rid of the CEL and the dealer told me if it didn’t come back then I wouldn’t need a servo buddy or ESRM.

I have only ridden it back from the dealer, about 10 miles, and the CEL is still gone. I didn’t think a map would clear it.
Is this normal? I’m happy that I don’t have to buy something else.
Mr_nobody is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-12-2018, 01:13 PM
Site Supporter
Commentator
Main Motorcycle: Very fast 675
Official Leathers Tester
 
Will's Avatar
 
Join Date: Jan 2002
Location: Seattle, WA
Posts: 8,448
Other Motorcycle: DRZ 400 Bad Idea
Extra Motorcycle: Mad Max the Husqvarna
I'm not sure how the exhaust on a 2015 is configured, but it doesn't surprise me too much. The servo operates a flapper in the exhaust. There was plenty of room for that equipment in earlier models with an underseat exhaust. But 2015, it may have been located in the end can, which means the TOR map would solve the problem. Or, maybe I don't know at all. Either way, if the map worked, then it's great.

Will
It's a squid thing. You wouldn't understand.

Go soothingly on the grease mud, as there lurks the skid demon.
Will is offline  
post #3 of 4 (permalink) Old 11-13-2018, 02:06 AM Thread Starter
Newbie
New Member
 
Join Date: Oct 2018
Posts: 4
The map took care of the CEL, I’ve only ridden it twice so far.
wpanik likes this.
Mr_nobody is offline  
 
post #4 of 4 (permalink) Old 05-21-2019, 01:16 PM
Grand Prix 250
Member
 
wpanik's Avatar
 
Join Date: May 2019
Posts: 42
Quote:
Originally Posted by Mr_nobody View Post
The map took care of the CEL, Iíve only ridden it twice so far.


That map likely just told the ECU to ignore input from the flapper. You should be set!


Sent from my iPhone using Tapatalk
wpanik is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Comp Werks slip on for 2013+ stock exhaust WordisBond Street Triple Forum 11 05-10-2018 12:21 PM
Vance and Hines Slip on's on my Thruxton R...Map?? CRFan250 Water Cooled Twins Technical Talk 2 03-05-2018 04:44 PM
2013 Street Triple trouble starting + possible clutch slip? erkishhorde Street Triple Forum 4 02-03-2017 01:46 AM
Arrow Slip On Install - gasket Hyperlite Street Triple Forum 8 06-29-2016 01:13 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome