Triumph Forum: Triumph Rat Motorcycle Forums

Triumph Forum: Triumph Rat Motorcycle Forums (https://www.triumphrat.net/forum.php)
-   Classic, Vintage & Veteran (https://www.triumphrat.net/classic-vintage-and-veteran/)
-   -   amal 930 brand new set up (https://www.triumphrat.net/classic-vintage-and-veteran/952784-amal-930-brand-new-set-up.html)

Baddonut 05-14-2019 01:52 AM

amal 930 brand new set up
 
Hi gents
my old amals were well worn and slides sticking so tried the refurb no joy. Got new carbs and fitted them today. Read the threads and was carful with the float position and the balancing. Bike started on choke, once chock out and bike ran slightly high revs but ok (used the 3/16 drill slide setup and fine tune). After a few minutes the revs would jump up 1500RPM and then drop with small but occasional backfires. Carbs are new so cant be a issue with pilot jet. Mixture screws 1 1/2.
I would appreciate any advice, tomorrow will be another day of fiddling!
Cheers and time for another IPA...

tridentt150v 05-14-2019 02:57 AM

Air leak maybe? or check your fuel level?

Caulky 05-14-2019 04:01 AM

Before playing with the carbs, the ignition timing must be spot-on.
Are you using 'Triumph' thick O-rings? Not the skinny Amal ones. Do you have the correct washers, cups, etc for the mounts?
Use a thin smear of grease to hold the O-rings in place.
Although 1 1/2 turns out for the air/mixture screw is nominal, the set-up must be tuned.
*note the gap between the flanges, with the thick O-rings at the start of the video.

Tuning about 3 1/2 minutes into this:

SPWL 05-14-2019 04:24 AM

Did you clean out all the carb with compressed air before fitting? My new Amal I fitted last year had tiny bits of swarf in the jets and fuel ways.

Steve

tridentt150v 05-14-2019 05:46 AM

I prefer doing one side at a time, easier to hear the changes in tune and much much easier to set a 1500rpm fast idle on each cylinder - before trimming back to 800-1000rpm as the final step.
I'm not convinced that the chap in that clip has achieved the best tune for his bike tbh.

Code Man 05-14-2019 03:29 PM

I bought new Amal Premier's cleaned out all the jets (did not see any debris) and checked the float level before installing them with the thin o-ring. The bike ran like crap! Would not idle sounded like it was missing intermittently and got worse as the engine warmed up. Mixture screw adjustment made no difference.
Took the carbs back off and rechecked everything with special attention to the pilot jets and the float level. Still no debris that I could see came out of any of the passage ways. When reinstalling carbs this time I installed the thicker o-rings between carbs and the manifolds. Kicked it about five times before it would start and it felt like it was only running on one cylinder and then it cleard out when I revved it up. So threw on my helmet and went for a ride. Went up the street (up hill) in front of my house and the engine ran good except it missed once but other than that it ran good. Got about a mile away and stopped at a stop sign and the engine felt like it wouldn't idle and ran a little rough until I reved it up a few times.
Now I was on a street with no stop signs or stop lights for about five miles and the speed limit is 45mph. The bike ran beautifully never skipped a beat until the end of that street at the stop sign it coughed and spit back through the carbs a couple times. I reved it up a couple times cause thought it might die if I let it idle.
I was close to the freeway so I jumped on it and headed back home. The bike ran beautifully through all the gears while getting up to freeway speeds 65mph. After riding about four miles I pulled off to the side of the road at a large turnout to see if it would idle. For some reason it was idling at 2000 rpm's and then it started to miss and run rough again. So I reved it up a few times cleared it out and jumped back on the freeway where again it ran good getting back up to speed but at the bottom of the off ramp it coughed a couple times and I kept revving the engine to keep it running and took off again.
No other stops getting back to my house but the last half mile is all down hill until I get to my driveway that is up hill for 100 ft. Made it up my driveway but t he engine was missing and couldn't be cleared out by revving it and would not idle then died. Couldn't restart it right away but let it sit for 5 minutes or so and it started right up and sounded good for about 30 seconds and started running rough again spitting back through the carbs now and then.

My old carbs were not that bad but just off idle when accelerating the engine would skip just a little and then be fine until accelerating above 65mph it would start to sputter and miss again. So I took my old carbs off the shelf took them apart and cleaned them before reinstalling them. The bike ran really good except for the little stumble right off idle. Took the bike for a 40 mile ride and was surprised at how good it ran. I could not get it to miss at all at higher speeds like it did before.

I'm thinking the float level must be to high on new carbs at 1/32 or 1/16 inch above the bowl rim. I'll try them at even with the rim next time I have them apart and see how that works. For now the weather is nice and the old carburetors are good enough!

Baddonut 05-14-2019 08:19 PM

Trident t150 yeah I figuered air leak so took em off again and used a decent gasket seal around the Amal o ring and the spacer gasket both sides. Made a difference and the bike started with choke. Adjusted the tick over slightly down as was running high. Now I took down the road and ran like crap, much like Codemans problems. The mixture is really too rich both plugs black left hand especially so. With revs on the vaccum on right carb is good the left not so strong. Will adjust mixture tomorrow and try again. Knee is giving out kickking the beast into life now!

Baddonut 05-14-2019 08:20 PM

Hi Steve
no I washed all out with clean gas. Didnt find any swarf...!

Baddonut 05-14-2019 08:25 PM

Hi Caulky
didnt use the triumph o ring used the amal one. Sealed the crap out of it later with a good fuel gasket sealant. Ran after this but as with codeman. Only difference mine wont start without choke. And choke come on all by itself, solved that now. Crappy run down the road and will not rev out. Onwards and upwards!

Baddonut 05-15-2019 11:58 AM

Was in Pollock Pines last friday Codeman. Two great friends of ours live there. We had a good meal at the community center! Am coming up to Folsom thursday to meet up with them for some lunch and to pick up my new Fatbob. If I get the Trumpet running good will bring it up.
I set the new carbs .06 below the rim. Unfortunately cant use the old carbs as the had a bend in the barrels and the slides stuck hence the new ones.


All times are GMT -4. The time now is 03:07 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome