Engine cuts out - Error code P1698 - Page 2 - Triumph Forum: Triumph Rat Motorcycle Forums
Air Cooled Twins Technical Talk Technical Talk for Hinckley Triumph Twins: Bonneville, Bobber, T100, Speedmaster, America, Thruxton, and Scrambler. Sponsored by: triumphtwinpower.com

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 17 (permalink) Old 05-17-2019, 09:55 AM
Grand Prix 125
Main Motorcycle: Speedmater 2009 EFI
Member
 
Speedy92's Avatar
 
Join Date: Jul 2016
Location: Split - Croatia
Posts: 34
Thank you guys very much, currently I have 2 problems to check
Without any reason , while checking rectifier if its good or bad ( i disconnect it from the stator plug, and check by multimeter) and realise that it is good, also checked all fuses and they look good, I put back everything back in place try to start it, realise that neutral swich is gone bad, so I have to check that one and the stator.
Speedy92 is offline  
Sponsored Links
Advertisement
 
post #12 of 17 (permalink) Old 05-17-2019, 11:25 AM
Formula Extreme
Main Motorcycle: 2009 Scrambler
Senior Member
 
Join Date: Aug 2009
Location: West Yorkshire UK
Posts: 531
Quote:
Originally Posted by Forchetto View Post
I think you must mean this definitive one by @DEcosse :


https://www.triumphrat.net/speed-tri...r-upgrade.html
Yes that's the one, very informative
Ade-955i is online now  
post #13 of 17 (permalink) Old 05-18-2019, 05:54 AM
Grand Prix 125
Main Motorcycle: Speedmater 2009 EFI
Member
 
Speedy92's Avatar
 
Join Date: Jul 2016
Location: Split - Croatia
Posts: 34
Ok, neutral switch was disconnected , probably bumpy roads or something , now thats ok, but still the battery remains on same voltage ( i.e. 12.05V ) while engine running on 900rpm or 4000rpm 😕 now I'm going to check stator connection and see what it will show me
Speedy92 is offline  
 
post #14 of 17 (permalink) Old 05-18-2019, 08:06 AM
Grand Prix 125
Main Motorcycle: Speedmater 2009 EFI
Member
 
Speedy92's Avatar
 
Join Date: Jul 2016
Location: Split - Croatia
Posts: 34
All in all its rectifier...any suggestions on which one to buy or order OEM from triumph site?
Speedy92 is offline  
post #15 of 17 (permalink) Old 05-18-2019, 08:23 AM
Grand Prix 125
Main Motorcycle: Speedmater 2009 EFI
Member
 
Speedy92's Avatar
 
Join Date: Jul 2016
Location: Split - Croatia
Posts: 34
Quote:
Originally Posted by Speedy92 View Post
All in all its rectifier...any suggestions on which one to buy or order OEM from triumph site?
If somebody can please find instructions on how to put rick mosfet r/r , because I would like to put that one..and link on ebay or some other site so I can order it ? Thank you very much in advance!!
Speedy92 is offline  
post #16 of 17 (permalink) Old 05-18-2019, 10:58 PM
Site Supporter
Supernova
Main Motorcycle: 2009 Bonneville SE
Lifetime Premium
 
Forchetto's Avatar
 
Join Date: Jun 2009
Location: Asturias, Spain
Posts: 20,648
Other Motorcycle: Yamaha XV1100
Extra Motorcycle: Qingqi QM200GY-BA
Quote:
Originally Posted by Speedy92 View Post
If somebody can please find instructions on how to put rick mosfet r/r , because I would like to put that one..and link on ebay or some other site so I can order it ? Thank you very much in advance!!

The Rick's part number for the Speedmaster would be 10-004H:

https://ricksmotorsportelectrics.com...ulator-10_004H

Instalation should be straight forward, as it fits with the same two bolts and it's provided with a suitable connector that plugs into the existing one.

Order direct from makers or Amazon:

https://www.amazon.com/dp/B004AGMDUA...gateway&sr=8-1

Ebay has them as well, although in the end they all come from the States:

https://www.ebay.com/sch/i.html?_fro...-004H&_sacat=0


Do at least check that the connector that joins the stator to the main loom and it's attached to the thicker of the two cables that exit from the alternator triangular cover is OK. Many have burned or melted and fitting a new regulator will be no good, see the link provided earlier which has among other useful diagnostic tips a photo of a burned connector on post 7:


https://www.triumphrat.net/speed-tri...r-upgrade.html

Last edited by Forchetto; 05-19-2019 at 04:34 AM.
Forchetto is offline  
post #17 of 17 (permalink) Old 05-20-2019, 12:05 PM
Grand Prix 125
Main Motorcycle: Speedmater 2009 EFI
Member
 
Speedy92's Avatar
 
Join Date: Jul 2016
Location: Split - Croatia
Posts: 34
Thank you very much!
Just ordered one from ebay, as soon as I test it I'll let you know 😄
Speedy92 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options
All posts must adhere to Forum Rules

Register Now



In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
error code? triumphtimes Daytona Deliberations 3 11-05-2008 10:59 PM
s4 error code t8 Justice Strike Triumph SuperSports 0 03-29-2008 05:01 PM
tt600 error code xdvst8x Triumph SuperSports 5 03-16-2007 12:04 PM
Engine error code with tuneboy roadkill Speed Triple Forum 4 02-13-2007 09:36 AM
'02 S3 error code help - P0462 Granitsky Speed Triple Forum 3 10-22-2005 02:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome