*** did I do wrong now ? - Triumph Forum: Triumph Rat Motorcycle Forums
» Main Menu

Discussion Forums
 » Twins
 » Tiger
 » General
 » RAT

Features
 » Blogs

Motorcycle.com Links

Contribute
 » Photo

Motorcycle Forums
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games

Twins Technical Talk Technical Talk for Hinckley Triumph Twins: Bonneville, T100, Speedmaster, America, Thruxton, and Scrambler.

Reply
 
LinkBack Thread Tools Display Modes
Old 12-05-2012, 09:44 PM   #1 (permalink)
Member
Supersport 400
Main Motorcycle: 07 Thruxton
 
Mekagojira's Avatar
 
Join Date: Mar 2012
Location: Los Angeles
Posts: 81
Extra Motorcycle: '75 CB750 caffinated
*** did I do wrong now ?

Hi any help appreciated !

Gas leaking from Pod.

Just had carbs off to make sure the idle circuit was was clean as I was running lean at idle after installing BC air box delete. With Thier 42s and 140 jets. At 2.5 turns now.

Bike will turn over after much cranking but does not stay on...

With pet cock on gas pours from left pod...

At least it was running yesterday if not ideally... Geez. What did I do wrong ? The carb assemble seemed straight forward at the time...


Sent from my iPhone using Motorcycle.com Free App
Mekagojira is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-05-2012, 10:35 PM   #2 (permalink)
Senior Member
Grand Prix 500
Main Motorcycle: Bonneville
 
Join Date: Oct 2010
Location: Tasmania
Posts: 131
Other Motorcycle: Honda Postie
Extra Motorcycle: Suzuki DL650 V Strom
Hello
Sounds like the float valve is not sealing off. Off with the carbs and check it out. Also check that jets are properly installed.
Tasmaniablue is offline   Reply With Quote Quick reply to this message
Old 12-05-2012, 10:41 PM   #3 (permalink)
Senior Member
Formula Extreme
 
Join Date: Sep 2003
Location: North Augusta SC
Posts: 711
Quote:
Originally Posted by Mekagojira View Post
Hi any help appreciated !

Gas leaking from Pod.

Just had carbs off to make sure the idle circuit was was clean as I was running lean at idle after installing BC air box delete. With Thier 42s and 140 jets. At 2.5 turns now.

Bike will turn over after much cranking but does not stay on...

With pet cock on gas pours from left pod...

At least it was running yesterday if not ideally... Geez. What did I do wrong ? The carb assemble seemed straight forward at the time...


Sent from my iPhone using Motorcycle.com Free App
Two things to check... float sticking (fix by draining float bowl & tapping the bowl w/a screwdriver handle)... and I know this sounds really stupid... but it has happened before... by any chance did you hook up the carb vent line to the petcock? The vent line is the piece of tubing (non "pre" kinked/shaped) that runs down to the lower plastic T fitting on the carbs...
SCbonneville is offline   Reply With Quote Quick reply to this message
Old 12-06-2012, 12:26 AM   #4 (permalink)
Member
Supersport 400
Main Motorcycle: 07 Thruxton
 
Mekagojira's Avatar
 
Join Date: Mar 2012
Location: Los Angeles
Posts: 81
Extra Motorcycle: '75 CB750 caffinated
Thanks SCBonneville - wait where does the fuel line go? not to the T in the middle/ I don't think I ever saw a vent line - I have a thin rubber tube connecting the two carbs thats it. And then I have a fuel line from the tank… I very well may be confused.
Mekagojira is offline   Reply With Quote Quick reply to this message
Old 12-06-2012, 01:21 AM   #5 (permalink)
Senior Member
Formula Extreme
Main Motorcycle: '01 Triumph Bonneville
 
Join Date: Sep 2012
Location: Berkeley
Posts: 949
If you removed the Cali EVAP system, check that carb vent hose that SCBonneville mentioned.

I had the same problem as you just recently. Either my problem was a stuck float, or I think the rain shot water up into the carb vent hose, soaking the filter element I had stuffed in there and thereby making the venting almost non-functional.
luckyduck is offline   Reply With Quote Quick reply to this message
Old 12-06-2012, 07:39 PM   #6 (permalink)
Member
Supersport 400
Main Motorcycle: 07 Thruxton
 
Mekagojira's Avatar
 
Join Date: Mar 2012
Location: Los Angeles
Posts: 81
Extra Motorcycle: '75 CB750 caffinated
Yep. I'm an ass. Had the fuel line hooked up to the vent. Need to pay more attention during disassembly.




Sent from my iPhone using Motorcycle.com Free App
Mekagojira is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What went wrong kiwichrisbassett Tiger Chat 1 08-09-2010 01:17 PM
Wrong place, Wrong time rixmix Biker Hang-Out 8 02-24-2009 10:10 AM
wrong thing at wrong time fugitive Biker Hang-Out 9 09-16-2008 08:03 PM
Wrong primary-case = wrong timing happyray Classic, Vintage & Veteran 3 04-05-2007 10:27 AM
Did I use the wrong oil? Berta Twins Technical Talk 7 03-06-2007 04:07 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 03:45 PM.



Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0