Bonnie issue's - Page 3 - Triumph Forum: Triumph Rat Motorcycle Forums
Twins Technical Talk Technical Talk for Hinckley Triumph Twins: Bonneville, T100, Speedmaster, America, Thruxton, and Scrambler.

LinkBack Thread Tools Display Modes
post #21 of 25 (permalink) Old 12-04-2012, 06:42 PM
Grand Prix 250
Main Motorcycle: 2010 Bonneville (mags)
psychodeathbot's Avatar
Join Date: May 2012
Location: Saint Paul, MN, USA
Posts: 76
Other Motorcycle: BMW R1150R
Extra Motorcycle: Masi CX (man-powered)
Originally Posted by ozbon View Post
My interpretation of a, "not a cold weather bike" would point more towards a cheap @rsed battery. Unless you live in the Snowy Mountains you shouldn't have any problems.
I posted about this recently:

From the sounds of things, there should be enough juice...?
psychodeathbot is offline  
Sponsored Links
post #22 of 25 (permalink) Old 12-04-2012, 07:24 PM
Senior Member
Formula Extreme
Main Motorcycle: 01 Bonneville
Join Date: May 2011
Location: xxxxxxxxxx
Posts: 733
I have a mid-production 2001 with 55K on it. I have replaced the cam cover gasket once about 1,000 miles ago. I had reused this gasket at least three times without issue. Use an allen key on the cam bolts. Do not use a ratchet, over leverage will pull the thread.

I have had ZERO electrical system problems. The original Battery lasted 2 got killed because I marshmellowed the battery by leaving the lights on all night. The second battery lasted 8 years. I am on my third. I have no cold weather problems...the bike spent the first 9 years of her life in NY without issues.

I have replaced spokes once, and relaced the wheel once. This is known issue with early bikes and newer bikes dont suffer from this nuisance.

The Bonneville is a well engineered durable machine with superior reliability.
DUCKMAN is offline  
post #23 of 25 (permalink) Old 12-05-2012, 10:52 AM
Senior Member
Main Motorcycle: 2012 Rocket III Roadster
RickMcCl's Avatar
Join Date: Oct 2012
Location: Weeki Wachee, Fl USA
Posts: 203
Other Motorcycle: N/A
Greetings, all!

I have an '08 T100 that I bought used, and am wondering if the spoke issue (rear wheel, I believe?) was still going on in'08?


RickMcCl is offline  
post #24 of 25 (permalink) Old 12-05-2012, 01:34 PM
Driftless Moderator
Site Supporter
SOTP Vintage Series
Main Motorcycle: 2008 Bonneville Black
BonnieBlack's Avatar
Join Date: Aug 2008
Location: Fountain City, WI
Posts: 7,130
Other Motorcycle: Spousal 2009 Bonnie Black
Do you have these hubs Rick?

Seems like some think there was a design flaw that that hub design addressed. Some seem to think you just need to check your spokes pretty regularly and you'll be fine. I tend to tap all mine with a screwdriver whenever I have the rear wheel off the ground and listen for any duller sounding pings.
BonnieBlack is offline  
post #25 of 25 (permalink) Old 12-05-2012, 05:08 PM
Senior Member
Main Motorcycle: 2012 Rocket III Roadster
RickMcCl's Avatar
Join Date: Oct 2012
Location: Weeki Wachee, Fl USA
Posts: 203
Other Motorcycle: N/A
Thanks for the info!

RickMcCl is offline  
Sponsored Links

Quick Reply
All posts must adhere to Forum Rules

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
No issue's :) tri955i Daytona Deliberations 5 04-22-2012 10:10 PM
CONFUSED !!! Wire issue's??? cj7jeepthing Twins Technical Talk 1 02-24-2011 04:20 AM
bonnie america front axle same as regular bonnie? smcquilling Twins Technical Talk 1 01-07-2010 01:01 PM
Hey fellow "Bonnie" owner i saw you yesterday on black "Bonnie" . Stealthrider Twins Talk 3 12-05-2005 02:35 PM
Put up pics of my standard bonnie/thrux/black bonnie mutation faffyface Twins Talk 12 08-09-2005 12:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome