Neutral light - Triumph Forum: Triumph Rat Motorcycle Forums
» Main Menu

Discussion Forums
 » Twins
 » Tiger
 » General
 » RAT

Features
 » Blogs

Motorcycle.com Links

Contribute
 » Photo

Motorcycle Forums
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games

Twins Talk Discussion of Hinckley Triumph Twin related matters and topics.

Reply
 
LinkBack Thread Tools Display Modes
Old 11-18-2012, 06:32 PM   #1 (permalink)
Senior Member
Formula Extreme
Main Motorcycle: 2014 Thruxton
 
eric nyc's Avatar
 
Join Date: Sep 2012
Location: Brooklyn
Posts: 569
Neutral light

My neutral light has stopped working. A couple weeks it was working sporadically and now it's just not at all. What are the possible causes? Clearly I hope it's something simple like a blown bulb, electrical short, or loose lead. But is there any chance it's a problem down in the gear box? I'm not tearing down and cracking the case just to get an idiot light working, but what's a good diagnostic plan?


Sent from my iPhone using Motorcycle.com Free App
eric nyc is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-18-2012, 08:25 PM   #2 (permalink)
Senior Member
Formula Extreme
Main Motorcycle: Bonneville se
 
mr1bienvenu's Avatar
 
Join Date: Aug 2011
Location: Lake Charles, Louisiana
Posts: 440
Here is everything you need to know. Enjoy.

http://www.triumphrat.net/twins-tech...ch-boring.html
mr1bienvenu is offline   Reply With Quote Quick reply to this message
Old 11-18-2012, 08:41 PM   #3 (permalink)
Lifetime Premium
Site Supporter
Formula Extreme
Main Motorcycle: Scrambler
 
Olhogrider's Avatar
 
Join Date: Sep 2011
Location: Concord California
Posts: 745
Other Motorcycle: Sold
Extra Motorcycle: Gone
I had the same problem on both bikes. It is caused by a loose female spade lug. No that was NOT racist or sexist. That is what the connector is called! You will find it on the bottom of the engine near the oil filter. Pinch it a bit to make it more snug before reinstalling it.
__________________
Damned Dirty Biker!
Olhogrider is offline   Reply With Quote Quick reply to this message
Old 11-19-2012, 09:55 AM   #4 (permalink)
Senior Member
SOTP Vintage Series
Main Motorcycle: 2005 Bonneville Blue 790
 
Join Date: Sep 2006
Location: Central Maryland, USA
Posts: 7,858
Other Motorcycle: 1973 CB450, long gone
They do fail. Mine was leaking a little bit of oil through the switch.

Hints if you have to replace it:

You don't have to drain the oil, although some oil will drip out.

I found it very hard to properly (securely) re-attach the connector because it's so difficult to access in that recess; angled long-nose pliers were helpful.

Buy the Triumph part and use the sealing washer included with it; apparently the thickness of the washer is important.
__________________
Marty
2005 Bonneville Blue 790cc, AI removed, Staintunes RC, no snorkel, inlet enlarged, 118/40/NBZT "Thruxton" needles/1 shim/3 turns, Ikon 7610s, Ricor Intiminators, Dunlop GT501s, D9 gauge panel, tachometer.

Last edited by Baltobonneville; 11-19-2012 at 09:57 AM.
Baltobonneville is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Neutral light went out, then.... Riven Twins Technical Talk 11 03-28-2011 11:49 PM
Neutral light doubles a Charging light ? NorthernThrux Twins Technical Talk 9 03-23-2011 05:08 PM
neutral light,,,,, born to be mild T3 Sport / Touring Forum 18 10-10-2009 04:32 AM
neutral light zoombass Hinckley Classic Triples 1 05-18-2009 07:24 AM
Neutral light comes and goes..... SpaceCoastRat Twins Technical Talk 6 05-12-2009 03:13 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 09:55 PM.



Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.6.0