Problems !!!! - Triumph Forum: Triumph Rat Motorcycle Forums
» Main Menu

Discussion Forums
 » Twins
 » Tiger
 » General
 » RAT

Features
 » Blogs

Motorcycle.com Links

Contribute
 » Photo

Motorcycle Forums
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games

Trophy 1200 Triple This is a dedicated sub forum for the new Trophy triple.

Reply
 
LinkBack Thread Tools Display Modes
Old 01-22-2013, 06:45 PM   #1 (permalink)
New Member
Grand Prix 125
Main Motorcycle: Triumph Trophy SE
 
Join Date: Jan 2013
Location: Baton Rouge, La.
Posts: 21
Problems !!!!

Wanted to go for a ride this morning and the Trophy would not start. The display goes blank and the engine will not turn over, BUMMER !!! Contacted dealer and they are working on the problem.
carey is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-22-2013, 07:49 PM   #2 (permalink)
Lifetime Premium
Site Supporter
SuperSport
Main Motorcycle: 2010 Bonneville T-100
 
Ropeferry's Avatar
 
Join Date: Oct 2010
Location: New Hampshire
Posts: 995
Other Motorcycle: 2005 Bonniville 904
Kill switch?

I speak from experience....
__________________
"I knew that topless lady had something up her sleeve,"

John Prine
Ropeferry is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 09:48 AM   #3 (permalink)
Member
Grand Prix 125
Main Motorcycle: 2013 TrophySE
 
Join Date: Sep 2012
Location: Canada
Posts: 38
Other Motorcycle: 1982 Honda GL1100
This most likely not the problem, but worth a try. Page 97 of the owners manual says:

The motorcycle is equipped with starter lockout switches. The switches prevent the electric starter from operating when the transmission is not in neutral with the side stand down.
2wheeler is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 09:05 PM   #4 (permalink)
New Member
Grand Prix 125
Main Motorcycle: Triumph Trophy SE
 
Join Date: Jan 2013
Location: Baton Rouge, La.
Posts: 21
Dealer picking up

Thanks guys but neither of the suggestions is the problem. I charged the battery and it started. The engine light stays on. Dealer is picking up tomorrow.
carey is offline   Reply With Quote Quick reply to this message
Old 01-24-2013, 11:23 PM   #5 (permalink)
New Member
Minitwins
 
Join Date: Jun 2005
Location: Charleston, South Carolina, USA
Posts: 16
For what it's worth, I had precisely the same problem with my new TROPHY purchased a week ago Monday.

The dealer determined that the battery shipped with the bike was bad; once he replaced it, everything was fine. Years ago, when I got back into motorcycles after a long hiatus, I had the same thing happen with a brand new SUZUKI LC 1500 -- bad battery shipped with the new bike. Once it too was replaced, all was well.

Perhaps your dealer will end up doing the same thing -- in any event, good luck.
__________________
Be safe out there . . . PLEASE!
Bubbaslye is offline   Reply With Quote Quick reply to this message
Old 01-27-2013, 11:45 AM   #6 (permalink)
New Member
Grand Prix 125
Main Motorcycle: Triumph Trophy SE
 
Join Date: Jan 2013
Location: Baton Rouge, La.
Posts: 21
Dealer picked up bike

Thanks Bubbasly, I will pass that info on. The latest is that the systems light stays on. This indicates a malfunction and puts the bike in "limp mode" (it's in the manual...lol) so you can get home. The good thing, the dealer drove 150mi. to pick it up. So far I like Hattiesburg cycles in Mississippi !!!
carey is offline   Reply With Quote Quick reply to this message
Old 01-30-2013, 10:14 PM   #7 (permalink)
New Member
Minitwins
 
Join Date: Jun 2005
Location: Charleston, South Carolina, USA
Posts: 16
Let us know...

Hope your dealer pinpoints the problem and solves it...let us know, and
good luck!
__________________
Be safe out there . . . PLEASE!
Bubbaslye is offline   Reply With Quote Quick reply to this message
Old 01-30-2013, 11:26 PM   #8 (permalink)
New Member
Grand Prix 125
Main Motorcycle: Triumph Trophy SE
 
Join Date: Jan 2013
Location: Baton Rouge, La.
Posts: 21
Picking bike up

I will be picking up the bike Thur. morning. The dealer said they had to "flash" the computer. I guess that's like a reboot. We'll see what happens. I will post the outcome this weekend. Hope to do some riding !!
carey is offline   Reply With Quote Quick reply to this message
Old 01-31-2013, 11:23 PM   #9 (permalink)
Member
Grand Prix 250
Main Motorcycle: 2013 Trophy
 
Carl_in_AZ's Avatar
 
Join Date: Nov 2012
Location: Scottsdale AZ., USA
Posts: 58
Other Motorcycle: 2013 Trophy on order
I just had the strap on my left pannier pullout of the rivet and scrapped the cover on the cement.
Carl_in_AZ is offline   Reply With Quote Quick reply to this message
Old 02-01-2013, 12:39 PM   #10 (permalink)
Senior Member
Grand Prix 500
Main Motorcycle: 2010 Bonneville T100
 
Join Date: Jul 2011
Location: Canada
Posts: 109
these are some of the issues i fear.... it's a very techy ride... likely going to need firmware updates to correct problems... for many of you it's not an issue... for me, the closest dealer is over 150 miles away.... so to drive there for a 20 minute software/firmware update is a 4-5 hour ride (both ways).... not so pleasant....
kgerry is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU problems? hi_gonzilla Twins Technical Talk 40 02-17-2013 10:45 AM
.COM problems GrandPaulZ Classic, Vintage & Veteran 0 12-05-2011 10:00 AM
Problems with my STR rand4ll Street Triple Forum 15 11-18-2011 05:17 PM
Problems, problems & more problems - exhaust & carbs jlearman Twins Technical Talk 5 04-25-2010 11:20 AM
Has anyone had problems diagnosing tire problems? ohiorider Twins Technical Talk 1 07-18-2007 09:58 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 09:00 AM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.