Hi, All. - Triumph Forum: Triumph Rat Motorcycle Forums
The Welcome Center New to the Site? Please take a moment to introduce yourself. New members and members who have yet not posted MUST post their first post here to activate their profiles.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-12-2012, 02:48 PM Thread Starter
Senior Member
Grand Prix 500
Main Motorcycle: 1997 Thunderbird
Tburd97's Avatar
Join Date: Nov 2012
Location: Yuma, AZ
Posts: 118
Other Motorcycle: 2004 HD Vrod (VRSCB)
Extra Motorcycle: 2014 HD Ultra Limited
Hi, All.

Hello, Everyone. Glad to be here. The forum was recommended by a friend of mine after I bought my '97 TB w/8600 miles. Already have an issue, but I'll post in the triples.

Tburd97 is offline  
Sponsored Links

Quick Reply
All posts must adhere to Forum Rules

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome