2007 Bonneville Won't Start - Triumph Forum: Triumph Rat Motorcycle Forums
The Welcome Center New to the Site? Please take a moment to introduce yourself. New members and members who have yet not posted MUST post their first post here to activate their profiles.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-27-2012, 10:17 PM Thread Starter
New Member
Main Motorcycle: 2007 Bonneville
Join Date: Nov 2012
Location: Doylestown
Posts: 2
2007 Bonneville Won't Start

Replaced the original battery, new plugs, cleaned carbs.

Problem started after a short ride with sudden & total loss of power. Started again after 5 minutes, ran less than a minute stalled out again. Pushed it home. Started right after I re-installed carbs and ran long enough to rev a few times and adjust idle speed and seemed all good again then I shut it off. Thought I fixed it. Hasn't started since. Turns and turns and every so often gives one sputter like it wants to start but doesn't. Ran perfectly for 17k miles since I bought new. Always serviced including a costly valve adjustment by the dealer 2 years ago. Always use good gas etc....Didn't run it much this summer however when I did it ran right (until it stopped running).

Read a post about testing resistance through the plug leads and did so. Post said I should have seen 18k but I read around 12k. It suggested replacing the coil so I ordered the Nology coil today. I am not a mechanic by any stretch but am confident I can change the coil without a problem. Just not sure I am on the right track.

Any thoughts either way would be appreciated. I bought another bike in the spring and think the Bonneville is just pissed about it so I am being punished for the indiscretion.
Plamb is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-29-2012, 01:53 AM
Grand Prix 250
Main Motorcycle: 09 Triumph Bonneville
Join Date: Nov 2012
Location: Liberty, Missouri
Posts: 41
Other Motorcycle: 08 Victory Hammer
You could try the twin talk section.
goat-ee is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Triumph Forum: Triumph Rat Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter your valid email address, that can receive an automated confirmation message. Otherwise, you won't be able to gain full access.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 S3 - just started dying and then will not start.... vegas thruxton Speed Triple Forum 11 09-09-2011 01:52 AM
2007 No Start...faulty ecm? cam3281 Daytona675 Forum 2 10-05-2009 09:08 PM
2007 Speed Triple Will Not Start raydeje Speed Triple Forum 19 09-14-2009 08:36 PM
1-3 and now 1-4 - what a start to 2007! TonyD Biker Hang-Out 3 01-10-2007 03:41 AM
My 2007 sprint wouldn't start chefjohn Sprint Forum 1 01-08-2007 01:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On

For the best viewing experience please update your browser to Google Chrome